tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Bowen <kbo...@als.com>
Subject Re: apparent problem with work/ directory
Date Sat, 30 Aug 2008 11:14:49 GMT
When I run into behavior that sounds like what you describe, I
manually delete

        <TOMCAT>work/Catalina/localhost/<APPNAME>

before restarting.

--Ken

On Aug 29, 2008, at 5:00 PM, Jonathan Mast wrote:

> I refactored the POJO side of a webapp I have.  I basically moved some
> objects referenced by the JSPs into a new package.  I updated the jsps
> accordingly, by importing the new package with the PAGE directive at  
> the
> top.  I deleted the old version of the webapp, rebuilt it, and  
> restarted
> tomcat.
>
> It then started spewing errors, generated from the jsp's, about not  
> being
> able to find the old classes.  I am convinced that the errors lies  
> in the
> work/ directly, specifically the derived java sources of the jsp  
> were not
> updated when I restarted Tomcat.
>
> I know the problem is not in the webapp itself because i tested it  
> out on my
> Windoze box before deploying to Linux where the problem occured.  My
> question is: how do I force Tomcat to delete the "work" directory upon
> restarting or when I'm building from Ant?
>
> Thanks,
>
> Tomcat 5.5.17
> Java 1.4.2


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message