tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Lim" <charlesyc...@gmail.com>
Subject Re: Tomcat 6.0.18 startup Permission Denied Error:listen failed initializing endpoint
Date Fri, 08 Aug 2008 12:53:54 GMT
Finally the issue was solved. It was due to the Norman
Anti-virus+Firwall. Although I have disable the firewall, stopped all
Norman services that can be stopped, i still get the Permission Denied
error. Only after I have uninstalled Norman can Tomcat start.

After which I
1) installed AVG free antivirus to replace Norman,
2) activate User Account Control
3) activated Windows Vista Firewall (started automatically)

Tomcat was still able to start.

Also during this time, I have also send in support request to
Microsoft to see if Vista is the one causing the problem, below is
their initial steps to resolve it. Althought it did not solve my
problem, still like to attach it here to benefit others:

Let's focus on our issue. The issue may occur due to the user account
permission settings. Please follow the steps below to troubleshoot the
issue.

------------------------------ START OF SUGGESTION FROM MICROSOFT
SUPPORT -----------------------------------
Step1 Active and log in Vista's build-in administrator account
=================================
1. Click Start, click "All Programs", please find and open "Accessories" folder.
2. Please right-click on "Command Prompt" item and select "Run as
administrator".
3. Please type the following command line in to the coming window.

net user administrator /active:yes

Note: There is a space between "Administrator" and "/active:yes".

4. Log off the current account and log on the "Administrator" account.

Step 2 Turn off UAC (User Account Control)
============================
1. Click Start. Go to the Search textbox. Type MSCONFIG, and press Enter.
2. Click Tools.
3. Highlight Disable UAC, click Launch.
4. Restart the computer.
------------------------------ END OF SUGGESTION FROM MICROSOFT
SUPPORT -----------------------------------

Thanks Mladen for all your help. This thread should be able to help
others with the similar encounter.




On Wed, Aug 6, 2008 at 6:00 PM, Charles Lim <charlesyclim@gmail.com> wrote:
> Below is the result. Seems like the port is ok.
>
> C:\Users\Charles\Downloads\java\apache>openssl s_server -nocert -accept 8080
> Loading 'screen' into random state - done
> Using default temp DH parameters
> Using default temp ECDH parameters
> ACCEPT
>
>
> On Wed, Aug 6, 2008 at 5:54 PM, Mladen Turk <mturk@redhat.com> wrote:
>>
>> Charles Lim wrote:
>>>
>>> I try to run, but it says -nocert and -accept commands are invalid:
>>>
>>> C:\Downloads\test program>openssl -nocert -accept 8080
>>> openssl:Error: '-nocert' is an invalid command.
>>>
>>
>> Sorry, its
>> openssl s_server -nocert -accept 8080
>>
>> Regards
>> --
>> ^(TM)
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message