tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter <pcimr...@gmail.com>
Subject Re: Tomcat does not unpack WAR file (Tomcat 5.5.20)
Date Sun, 24 Aug 2008 09:28:09 GMT
It turns out that the problem IS connected to the ROOT.xml file under 
conf\Catalina\localhost.

As soon as I remove ROOT.xml, the ROOT.war unpacks.

This is what my ROOT.xml file looks like:

<Context cookies="false" path="" debug="1"/>

There has been some prior discussion around this topic. For example, see:

http://marc.info/?l=tomcat-user&m=116107471021645&w=2
http://marc.info/?l=tomcat-user&m=116302992202121&w=2

Is this a known issue / 'bug' with Tomcat 5?

:)

Pete

Johnny Kewl wrote:
>
> ----- Original Message ----- From: "Peter" <pcimring@gmail.com>
> To: <users@tomcat.apache.org>
> Sent: Friday, August 22, 2008 4:07 PM
> Subject: Tomcat does not unpack WAR file (Tomcat 5.5.20)
>
>
>> Hi
>>
>> When I drop a WAR file into the webapps folder on my dev machine - 
>> running Tomcat 6.0.16 - Tomcat unpacks it on startup.
>>
>> When I do the same on the production box - running Tomcat 5.5.20 - 
>> nothing happens.
>>
>> The WAR file that I am deploying is ROOT.war; there is a 
>> corresponding ROOT.xml under conf\Catalina\localhost. (I'm not sure 
>> if those details have any bearing on the problem - according to one 
>> archived post, there may be a connection.)
>>
>> On both machines, the <host> tags look identical:
>>
>>      <Host name="localhost"  appBase="webapps"
>>            unpackWARs="true" autoDeploy="true"
>>            xmlValidation="false" xmlNamespaceAware="false">
>>
>> Any assistance would be appreciated. :)
>>
>> Pete
>>
>> -- 
>> Peter Cimring
>> Software Developer
>> (: +972 52-545-9364
>> *: pcimring@gmail.com
>
> Pete, nothing comes to mind, you seem to have the bases covered...
> One possibility is that the existing ROOT web ap is busy...
> Maybe a thread running or something... TC will not start up the new 
> guy, if the old one cant let go..
>
> possibly from the manager console /manager/html tell the old one to 
> undeploy first maybe...
>
> Also just make sure from you dev environment that the ROOT context 
> path is ""
> really empty and not "root" which it maybe doing... wild guess ;)
>
> --------------------------------------------------------------------------- 
>
> HARBOR : http://www.kewlstuff.co.za/index.htm
> The most powerful application server on earth.
> The only real POJO Application Server.
> See it in Action : http://www.kewlstuff.co.za/cd_tut_swf/whatisejb1.htm
> --------------------------------------------------------------------------- 
>
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

-- 
Peter Cimring
Software Developer
(: +972 52-545-9364
*: pcimring@gmail.com

"/"Any sufficiently advanced technology is indistinguishable from 
magic."/ - Arthur C. Clarke

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message