tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Gordon <adam.gor...@readytalk.com>
Subject Tomcat admin webapp configuration with mod_jk
Date Wed, 13 Aug 2008 21:53:18 GMT
We currently use Apache/Tomcat and mod_jk for our webapp.  I've 
downloaded and installed (correctly, I think) the admin web app but am 
having trouble configuring Apache and Tomcat to recognize that the admin 
webapp is present.  I suspect it's simply a config issue, but can't 
figure it out.  Here's our original server.xml:

<Server port="11005" shutdown="SHUTDOWN" debug="0">

  <Service name="Tomcat-Apache">
    <Connector protocol="AJP/1.3"
               port="11009"
               URIEncoding="UTF-8"
               minSpareThreads="0"
               maxSpareThreads="0"
               maxThreads="3000"
               backlog="6000"
               debug="0"
               enableLookups="false"
               maxPostSize="-1"
               connectionTimeout="-1"/>

    <Engine name="Standalone" defaultHost="localhost" debug="0">

      <Host name="localhost" debug="0" appBase="webapps" unpackWARs="true"
            autoDeploy="true" liveDeploy="true" deployOnStartup="false">

        <Context path="" docBase="palomar" cookies="false"
                 debug="0" crossContext="true" allowLinking="true">
          <Resources docBase="" allowLinking="true"/>
        </Context>
      </Host>
    </Engine>
  </Service>
</Server>

I've tried adding another connector (on port 8080) and also adding 
another <context> based on the admin.xml file but nothing seems to be 
working correctly.  I have workers.properties configured to redirect to 
Tomcat and that's working b/c I'm getting a Tomcat 404 error and not an 
Apache one.  I don't care by which means I connect to the admin webapp 
(either via mod_jk or directly via another port, say 8080 but I just 
can't seem to figure the configuration issue out.

--adam

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message