tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: DefaultServlet doesn't set charset
Date Mon, 11 Aug 2008 14:04:04 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Markus,

Markus Schönhaber wrote:
| OK, I think I have, by and large, understood how the DefaultServlet
| works and added code to append the charset info (if wanted and
| applicable) to the Content-Type response header.
| What I ended up with is the same as if I had simply searched the code
| for all places where Content-Type is set and add my code there. Seems
| reassuring to me.

Have you rigged the servlet to add a static charset defined in, say,
web.xml or something like that? Is there any logic to guess the actual
charset? Are you actually setting the character set of the response's
Writer? I'd love to take a look at your patch.

I would definitely add some tests to verify correct behavior when the
charset is set to something that is not sane (like ";;;;").

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkigRtQACgkQ9CaO5/Lv0PCOMwCgvxUa1bbV4GhEQXgRB0i0WPAq
SVcAnRfhzT+Ej5qUgUAatnJtfkaS/fG5
=b0I8
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message