tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Kapitza <j.kapi...@schwarze-allianz.de>
Subject Re: Tomcat within Eclipse
Date Mon, 11 Aug 2008 07:14:33 GMT
Sam Wun schrieb:
> Hi,
>
> Can anyone tell me how to resolve the followoing exception?
> and how do I know whether tomcat service is really running.
>
> 11/08/2008 14:47:47 org.apache.catalina.core.AprLifecycleListener init
> INFO: The APR based Apache Tomcat Native library which allows optimal
> performance in production environments was not found on the
> java.library.path: C:\Program
> Files\Java\jre1.6.0_07\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program
> Files/Java/jre6/bin/client;C:/Program
> Files/Java/jre6/bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;d:\ant171\bin;D:\apache-maven-2.0.9\bin;C:\Program
> Files\Nmap
> 11/08/2008 14:47:47 org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> 11/08/2008 14:47:47 org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 502 ms
> 11/08/2008 14:47:47 org.apache.naming.NamingContext lookup
> WARNING: Unexpected exception resolving reference
> java.io.IOException: Cannot rename original file to C:\Program
> Files\Apache Software Foundation\Tomcat 6.0\conf\tomcat-users.xml.old
>   
is this location writeable?
> SEVERE: Catalina.start:
> LifecycleException:  No UserDatabase component found under key UserDatabase
>   
chain error ???
> 	at org.apache.catalina.realm.UserDatabaseRealm.start(UserDatabaseRealm.java:261)
> 	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1037)
> 	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
> 	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
> 	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
> 	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> 	at java.lang.reflect.Method.invoke(Unknown Source)
> 	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
> 	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
> 11/08/2008 14:47:47 org.apache.catalina.startup.Catalina start
> INFO: Server startup in 104 ms
>   
tomcat is running but with no userdatabase (?)
> 11/08/2008 14:49:20 org.apache.catalina.core.StandardServer await
> WARNING: StandardServer.await: Invalid command 'GET / HTTP/1.1' received
>   
i think tomcat can't do anything with no userdatabase so all commands 
are invalid (?)


Jens Kapitza

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message