tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Setting CATALINA_BASE failed with tomcat-6.0.18
Date Thu, 07 Aug 2008 06:37:55 GMT
Zemian Deng wrote:
> am I sure? I think it is.
> 
> Well, I gave explicit 4 little instructions to repeat exactly what I found.
> 
> I read your post and by simply touch/create a empty file under
> $CATALINA_BASE/conf/logging.properties and that indeed fixed the problem and
> server starts up fine.


Thank's for that information, that's what I needed.

> So call it same problem or not, it's up to you guys. All I am saying is that
> using the CATALINA_BASE doesn't work with 6.0.18, but worked previously.

We are now pretty sure it's the same problem. Thank's for reporting, 
I'll add a bugzilla issue.

> -Zemian

Rainer

> On Wed, Aug 6, 2008 at 5:45 PM, Rainer Jung <rainer.jung@kippdata.de> wrote:
> 
>> Are we sure, that you experience the same problem? In other words, is
>> CATALINA_HOME/conf/logging.properties missing in your setup and does the
>> suggested workaround to catalina.sh solve the problem for you?
>>
>> Regards,
>>
>> Rainer
>>
>> Zemian Deng schrieb:
>>> Hum... so it is a confirmed bug then. I don't see a ticket open on those
>>> threads. Should I create one?
>>>
>>> On Wed, Aug 6, 2008 at 11:14 AM, Rainer Jung <rainer.jung@kippdata.de
>>> wrote:
>>>
>>>> See also
>>>>
>>>> http://marc.info/?t=121803134200001&r=1&w=2
>>>>
>>>> Regards,
>>>>
>>>> Rainer
>>>>
>>>> Zemian Deng schrieb:
>>>>
>>>>  Hi Mark, I am away from a computer now. But the steps I gave to
>>>>> reproduce out of default download is only 4 steps!!!
>>>>>
>>>>> You can't see error using that?
>>>>>
>>>>> I guess I can check the log for the stacktrace later. The error on
>>>>> console did not give more than what I paste. And since the errror
>>>>> seems like it can't even start the server, I doubt more info from log.
>>>>> But I will check later.
>>>>> -Z
>>>>>
>>>>>
>>>>>
>>>>> On 8/6/08, Mark Thomas <markt@apache.org> wrote:
>>>>>
>>>>>> Zemian Deng wrote:
>>>>>>
>>>>>>> Hello list,
>>>>>>>
>>>>>>> When I try the following it works with tomcat-6.0.14, but failed
on
>>>>>>> tomcat-6.0.18
>>>>>>>
>>>>>>> $ mkdir -p /tmp/mybase/conf
>>>>>>> $ cp /opt/apache-tomcat-6.0.18/conf/server.xml /tmp/mybase/conf
>>>>>>> $ export CATALINA_BASE=/tmp/mybase
>>>>>>> $ /opt/apache-tomcat-6.0.18/bin/catalina.sh run
>>>>>>> Using CATALINA_BASE:   /tmp/mytomcatbase
>>>>>>> Using CATALINA_HOME:   /opt/apache-tomcat-6.0.18
>>>>>>> Using CATALINA_TMPDIR: /tmp/mytomcatbase/temp
>>>>>>> Using JRE_HOME:
>>>>>>> /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home
>>>>>>> Exception in thread "main" java.lang.NoClassDefFoundError:
>>>>>>>
>>>>>>> Is this a bug?
>>>>>>>
>>>>>> It would help if you provided more of the stack trace.
>>>>>>
>>>>>> Mark

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message