tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <>
Subject Re: tomcat5 and jaas
Date Tue, 05 Aug 2008 13:43:25 GMT
rafabbri wrote:
> I'm a beginner in this technology and I try to configure Tomcat 5.0.28 in
The 5.0.x series is no longer supported. It is also quote old. You shoudl 
consider upgrading to 5.5.x or better yet 6.0.x

> order to use JAASRealm as detailed in the next link 
Those are the docs for 5.5.x, not 5.0.x. This may well be different. You'll 
need to look at the docs that come with 5.0.28

> but these informations seem to be not enought for my knoweledge.
> I can't integrate jaas with tomcat, I don't know what I must write in
> web.xml and in server.xml 
> In my server.xml I wrote a section like this:
>   <Realm className="org.apache.catalina.realm.JAASRealm"                 
>          appName="Sample"       
> 	     userClassNames="sample.principal.SamplePrincipal"
>          debug="99"/>	  
> but I don't now what I must do for roleClassNames
You can ignore it - is is optional.


To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message