tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ne_fat_s <stefanla...@hotmail.com>
Subject Re: problem with tomcat-native 1.1.10 and tomcat 6.0.14
Date Fri, 01 Aug 2008 02:48:21 GMT

I have the same problem, but with tomcat 6.0.16 and tomcat-native 1.1.14.

I installed the libapr1, libapr1-dev, libssl, libssl-dev packages from
ubuntu hardy heron, and there were no problems when building the native
library. I added export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:<path to library>
to bin/startup.sh.

And that's it. When I start tomcat, using startup.sh, I get the same logs -

Aug 1, 2008 11:44:49 AM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.14.
Aug 1, 2008 11:44:49 AM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
[false], random [true].

And that's all she wrote. The process is running, but is not listening on a
port.

Mihai, did you solve this problem? Or does anyone else have a clue as to
what's wrong?

Thanks,
Stefan





Mihai COSTACHE wrote:
> 
> i have a working tomcat 6.0.14 and now i want to use tomcat-native
> beacause it use openssl and not java-ssl
> 
> so .. 
> 1) i installed tomcat-native 1.1.10 
> 2) i edited server.xml (added SSLCertificateFile, SSLCertificateKeyFile,
> SSLPassword and SSLProtocol="TLSv1" to HTTPS Connector ... for HTTP
> Connector
> nothing has changed)
> 3) started tomcat again ... no error .. but not tcp sockets (for 8080
> and 8443 ports)
> 
> only this i have in catalina.out
> 
> ----------
> Jan 23, 2008 7:29:12 PM org.apache.catalina.core.AprLifecycleListener
> init
> INFO: Loaded Apache Tomcat Native library 1.1.10.
> Jan 23, 2008 7:29:12 PM org.apache.catalina.core.AprLifecycleListener
> init
> INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
> [false], random [true].
> -----------
> 
> the tomcat is running but it doesn't listen on any port !!!
> 
> -----------
> bin/bash /sbin/runscript.sh /etc/init.d/tomcat-6 start
> tomcat    2736 58.8  3.3 675280 34696 pts/0    Sl   19:50   0:02
> \_ /opt/sun-jdk-1.6.0.03/bin/java -server -Xms256M -Xmx512M
> -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
> -Djava.util.logging.config.file=/var/lib/tomcat-6//conf/logging.properties
> -classpath
> /usr/share/tomcat-6/lib/:/usr/share/tomcat-6//lib:/opt/sun-jdk-1.6.0.03/lib/tools.jar:/usr/share/tomcat-6//bin/bootstrap.jar:/usr/share/tomcat-6//bin/tomcat-juli.jar
> -Dcatalina.base=/var/lib/tomcat-6/ -Dcatalina.home=/usr/share/tomcat-6/
> -Djava.io.tmpdir=/var/tmp/tomcat-6/ org.apache.catalina.startup.Bootstrap
> start
> --------------
> 

-- 
View this message in context: http://www.nabble.com/problem-with-tomcat-native-1.1.10-and-tomcat-6.0.14-tp15048117p18767329.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message