tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Kewl" <j...@kewlstuff.co.za>
Subject Re: Can't start tomcat within Eclipse.
Date Sat, 09 Aug 2008 17:41:42 GMT

----- Original Message ----- 
From: "Sam Wun" <swun2010@gmail.com>
To: "Tomcat Users List" <users@tomcat.apache.org>
Sent: Saturday, August 09, 2008 6:31 PM
Subject: Re: Can't start tomcat within Eclipse.


> Hi,
>
> this is a follow up of the problem I am having.
> In Ecllipse:
> I defined JAVA_HOME in eclipse as
> C:/Program Files/Java/jdk1.6.0_10/lib/tools.jar
> TOMCAT_HOME as
> C:/apache-tomcat-5.5.17
>
> Still in Eclipse:
> In the Tomcat option -> JVM Settings, I choose JRE1.6.0_07 for JRE, and
> C:/Program Files/Java/jdk1.6.0_10/lib/tools.jar for Classpath
>
> Is there anything wrong with my configuration/setup?
>
> Thanks
> Sam
>
> On Sun, Aug 10, 2008 at 1:00 AM, Sam Wun <swun2010@gmail.com> wrote:
>> sorry about the preivous email with a different subject.
>> Here is the quest with the right subject name:
>>
>> Hi, I have just configured Eclipse 3.4 with tomcat in windows vista.
>> The environemt is running JDK1.6 and JRE 1.5, but I have selected
>> jdk1.6 for the enviornemt.
>> When I press the Start Tomcat menu in the Eclispe menu bar, it thrown
>> the following exception in the Eclispe console:
>>
>> 10/08/2008 12:51:14 AM org.apache.catalina.startup.Bootstrap 
>> initClassLoaders
>> SEVERE: Class loader creation threw exception
>> java.io.IOException: The filename, directory name, or volume label
>> syntax is incorrect
>>       at java.io.WinNTFileSystem.canonicalize0(Native Method)
>>       at java.io.Win32FileSystem.canonicalize(Win32FileSystem.java:396)
>>       at java.io.File.getCanonicalPath(File.java:559)
>>       at 
>> org.apache.catalina.startup.ClassLoaderFactory.createClassLoader(ClassLoaderFactory.java:199)
>>       at 
>> org.apache.catalina.startup.Bootstrap.createClassLoader(Bootstrap.java:179)
>>       at 
>> org.apache.catalina.startup.Bootstrap.initClassLoaders(Bootstrap.java:103)
>>       at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:212)
>>       at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:409)
>>
>> How can I troubleshoot this error and what may be the issue that
>> caused this error?
>>
>> Thanks
>>

SAM, I not an Eclipse user....

But it look like your slashes are wrong... MS is backwards ;)

Not

C:/apache-tomcat-5.5.17

C:\apache-tomcat-5.5.17

If that doesnt work try

C:\apache-tomcat-5.5.17\bin

this is wrong as well..

C:/Program Files/Java/jdk1.6.0_10/lib/tools.jar

\

and if that doesnt work try...

"C:\Program Files\Java\jdk1.6.0_10"

You really should not have to show an IDE anything more than where Java 
is...

Good Luck ;)

I'm a whoosie, I use Netbeans... run setup, done... but real men use Emacs 
;)

---------------------------------------------------------------------------
HARBOR : http://www.kewlstuff.co.za/index.htm
The most powerful application server on earth.
The only real POJO Application Server.
See it in Action : http://www.kewlstuff.co.za/cd_tut_swf/whatisejb1.htm
---------------------------------------------------------------------------



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message