tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Kewl" <j...@kewlstuff.co.za>
Subject Re: Weird stack trace when reloading a webapp
Date Thu, 07 Aug 2008 19:45:05 GMT

----- Original Message ----- 
From: "Olivier Lamy" <olamy@apache.org>
To: <users@tomcat.apache.org>
Sent: Thursday, August 07, 2008 5:17 PM
Subject: Weird stack trace when reloading a webapp


> Hi,
> I use the ant deploy target :
>   <deploy url="${url}" username="${tomcat.user}" 
> password="${tomcat.password}"
>           path="/{webPath}" localWar="${warPath}" update="true"
> config="${contextPath}" />
>
> But in catalina.out, I have the following stack trace :
>
> INFO: Deploying web application archive dotw-trans.war
> 2008-08-07 15:04:38,942 INFO  impl.BasicTilesContainer : Initializing
> Tiles2 container. . .
> 2008-08-07 15:04:39,177 INFO  impl.BasicTilesContainer : Tiles2
> container initialization complete.
> 2008-08-07 15:04:39,185 INFO  access.TilesAccess : Publishing
> TilesContext for context: org.apache.catalina.core.Appli
> cationContextFacade
> 2008-08-07 15:04:39,247 INFO  filter.DotwFilterDispatcher : init
> DotwFilterDispatcher with encoding : UTF-8
> Aug 7, 2008 3:04:40 PM org.apache.catalina.loader.WebappClassLoader
> findResourceInternal
> INFO: Illegal access: this web application instance has been stopped
> already.  Could not load META-INF/services/org.ap
> ache.xerces.xni.parser.XMLParserConfiguration.  The eventual following
> stack trace is caused by an error thrown for de
> bugging purposes as well as to attempt to terminate the thread which
> caused the illegal access, and has no functional
> impact.
> Aug 7, 2008 3:04:40 PM org.apache.catalina.core.StandardContext start
> SEVERE: Error filterStart
> Aug 7, 2008 3:04:40 PM org.apache.catalina.core.StandardContext start
> SEVERE: Context [/dotw-trans] startup failed due to previous errors
>
> Any idea on the Could not load
> META-INF/services/org.apache.xerces.xni.parser.XMLParserConfiguration.
>
> My en is :
> - apache-tomcat-6.0.18
> - jdk1.6.0_06
> - solaris 10
>
> Any idea ?
>
> Thanks,
> --
> Olivier

Oliver is that the whole error message or did you abreviate it?
Does is say anything about a POST...

I tell you why, on complex applications I've seen something similar...

Anyway try this.... before you redeploy... open /manager/html and UNDEPLOY 
the old one... then run your script...
If it is the same thing... you wont get the error because its actually 
happening in the undeploy...
If that works then add another section to your ant script... first 
undeploy... then redeploy...

If it is the same thing... I've only noticed it on very complex apps....
Other thing I've noticed is that even when you get this weird message... the 
redeploy does work.
And you cant debug it... because TC is killing the thing... ide wont trap 
it...
And I think it only happens when there are classloaders in the webapp 
classloader... which would explain why the webapp class loader cant let 
go... the child still has references... anyway try the above, and I dont 
think its too serious... its a last complaint before it gets a bullet 
between the eyes ;)

.... maybe its the same thing...
---------------------------------------------------------------------------
HARBOR : http://www.kewlstuff.co.za/index.htm
The most powerful application server on earth.
The only real POJO Application Server.
See it in Action : http://www.kewlstuff.co.za/cd_tut_swf/whatisejb1.htm
---------------------------------------------------------------------------




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message