tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Kewl" <j...@kewlstuff.co.za>
Subject Re: Regarding Service Unavailable
Date Thu, 07 Aug 2008 10:59:58 GMT

----- Original Message ----- 
From: "welcome.partha" <parthasarathi@touchpointindia.com>
To: <users@tomcat.apache.org>
Sent: Thursday, August 07, 2008 9:47 AM
Subject: Regarding Service Unavailable


>
> i run my web application after started my apache-tomcat server,it 
> displayed
> service unavailable.If i refreshed it its run successfully.Actually
> sometimes its working initially ,sometimes i give refresh then only its 
> run
> successfully.
>

That message you getting in your browser sounds like its a custom message 
and not a browser error..

I think you have two webapps that depend on each other... guessing here

webapps dont start, when tomcat starts, they start only when called the 
first time...

So if one is called, and the other one is still sleeping... you get your 
error...
but now the other one has woken up, and so the second time ... all is good.

To make them wake up... try this...

add this to the one that should be awake first

<load-on-startup>1</load-on-startup>

add this to the one that you calling...

<load-on-startup>2</load-on-startup>

you stick it in web.xml..

Maybe...

Have fun?
---------------------------------------------------------------------------
HARBOR : http://www.kewlstuff.co.za/index.htm
The most powerful application server on earth.
The only real POJO Application Server.
See it in Action : http://www.kewlstuff.co.za/cd_tut_swf/whatisejb1.htm
---------------------------------------------------------------------------


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message