tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sandeep gelli" <sundee...@gmail.com>
Subject Re: nsapi_redirector.so file
Date Thu, 03 Jul 2008 10:41:47 GMT
Hi Rainer,

Below is the URL from which i have downloaded the 64-bit nsapi_redirector.so
file. When i use this file
http://apache.oss.eznetsols.org/tomcat/tomcat-connectors/jk/binaries/solaris/jk-1.2.26/sparc/

I receive the following error message when i use this file.

Sun ONE Web Server 6.1 B08/22/2003 12:37
[https-online-forms]: failure: CORE3170: Configuration initialization
failed: Error running init function load-modules: dlopen of
/usr/src/nsapi/lib/nsapi_redirector.so failed (ld.so.1: webservd: fatal:
/usr/src/nsapi/lib/nsapi_redirector.so: wrong ELF class: ELFCLASS64)
[https-online-forms]: failure: server initialization failed

So for compiling the src, i used gcc 3.3 version, which gave me a 250kb
file(which doesnt seems to be correct).My sun one webserver is running on
32-bit mode.

When i use the 32-bit so file, the server successfully starts up, and i can
see the title page. When i submit the page, i can see the logs in the tomcat
and tomcat successfully responding to the request. But, the webserver is
unable to get the response from the tomcat. The 404 status is from the
webserver.


Attached are my config files.


Thanks
Sandeep

On 7/3/08, Rainer Jung <rainer.jung@kippdata.de> wrote:
>
> As a first step, answering the questions in my previous mail would be
> helpful. As a secodn step, showing your configuration. Third: what do you
> mean by "page not found"? Is it a browser generated error, e.g. because the
> web server crashes and the browqser doesn't get an answer, or do your get a
> reply from the web server with status code 404, or maybe from Tomcat?
>
> Regards,
>
> Rainer
>
> sandeep gelli wrote:
>
>> Hi Rainer,
>>
>> Thanks for the prompt response. Let me explain my scenario. I am trying to
>> redirect the requests from sun webserver to tomcat. All worked fine with
>> my
>> windows pc(32-bit) and when trying to deploy the same in my solaris
>> system,
>> i am able to get the first page. After submitting the first page, i am
>> getting the page not found error.
>>
>> When checked in the nsapi.log, i dont see any errors.So, i thought it
>> could
>> be because of the nsapi_redirector.so, which is the only change made
>> transferring the application from windows to unix.
>>
>> Any advise on this would be of great help to me, as i am struggling with
>> this issue from the last two weeks.
>>
>> Thanks & Rgds
>> Sandeep Gelli
>>
>>
>> On 7/3/08, Rainer Jung <rainer.jung@kippdata.de> wrote:
>>
>>> Hi Sandeep,
>>>
>>> sandeep gelli schrieb:
>>>
>>> Hi,
>>>>
>>>> Can anyone help me providing nsapi_redirector.so file(64-bit version).
>>>> My
>>>> application is running on solaris sparc os 9, and sunone webserver 6.1
>>>> sp9.
>>>>
>>>> When i used the one available in the apache website, i am getting
>>>> ELFCLASS64
>>>> error. I tried building it, but getting the following error during the
>>>> make
>>>>
>>>> Whats the version you are using and what's the exact download URL of the
>>> .so file?
>>> What is the exact error message?
>>> What is the result of the command "file .../nsapi_redirector.so"?
>>>
>>> I would say: you are using the 32 Bit version of the Sun Web Server (as
>>> usual on a 64 Bit system and kernel, no problem with that). If it is the
>>> 32Bit web server, you need to download the 32 Bit nsapi_redirector.so. On
>>> the download page for the most recent version, it is named
>>> nsapi_redirector-1.2.26-sjsws6.1sp11.so.
>>>
>>> file.
>>>
>>>> gcc: unrecognised option pthread.
>>>>
>>>> Which version of gcc?
>>> Mine says "gcc: unrecognized option '-bar'" if I use an unknown option.
>>> Notice the "-" in front of the option. Did you remove the minus in front
>>> of
>>> pthread in the Makefile?
>>>
>>> However, i am still getting the build file which is just 250 kb. and also
>>> That seems to be too small.
>>>
>>> the class version error.
>>> Remove the added "-m64" from your compiler flags. Then you'll build a
>>> 32Bit
>>> version.
>>>
>>> Thanks
>>>
>>>> Sandeep
>>>>
>>>> Regards,
>>>
>>> Rainer
>>>
>>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
View raw message