tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Riaz, Bob" <Bob.R...@Pearson.com>
Subject RE: ContextListener executes twice
Date Tue, 22 Jul 2008 17:51:01 GMT
Thanks.
Does anyone know of a patch for this? I couldn't find one.

In org.apache.catalina.startup.WebRuleSet you'll see this twice:

digester.addCallMethod(prefix + "web-app/listener/listener-class",
                                "addApplicationListener", 0);


-----Original Message-----
From: Fu-Tung Cheng [mailto:futung.cheng@yahoo.com] 
Sent: Tuesday, July 22, 2008 12:13 PM
To: Tomcat Users List
Subject: RE: ContextListener executes twice

Might have to do with this:

Any declared listener will be reported as declared twice due to this bug
		
http://www.mail-archive.com/dev@tomcat.apache.org/msg23408.html

Fu-Tung

--- On Tue, 7/22/08, Caldarale, Charles R <Chuck.Caldarale@unisys.com>
wrote:

> From: Caldarale, Charles R <Chuck.Caldarale@unisys.com>
> Subject: RE: ContextListener executes twice
> To: "Tomcat Users List" <users@tomcat.apache.org>
> Date: Tuesday, July 22, 2008, 4:51 PM
> > From: Riaz, Bob [mailto:Bob.Riaz@Pearson.com]
> > Subject: RE: ContextListener executes twice
> >
> > > 1) Where is your webapp deployed?
> > On my dev machine - localhost. Is that what you mean?
> 
> No, what directory is it in?  Is it a .war or an expanded
> webapp?
> 
> > > 2) Do you have a META-INF/context.xml file inside
> your webapp?
> > <?xml version="1.0"
> encoding="UTF-8"?>
> > <Context path="/MyWebApp"/>
> 
> The path attribute is illegal here.  You don't really
> need a <Context> at all.
> 
> > > 3) Do you have a
> conf/Catalina/[host]/[appName].xml file?
> > <?xml version="1.0"
> encoding="UTF-8"?>
> > <Context
> >
> docBase="C:/..Path/NetBeansProjects/MyWebApp/build/web"
> path="/
> > MyWebApp "/>
> 
> The above will override the invalid one in
> META-INF/context.xml.
> 
> > > 4) What is the appBase setting for each of your
> <Host> elements
> > > in conf/server.xml?
> > <Host name="localhost" 
> appBase="webapps"
> 
> Do you happen to have a copy of your webapp deployed under
> Tomcat's webapps directory?  If so, that would account
> for the double initialization.
> 
> Does the problem occur when you run Tomcat independently of
> NetBeans, or only if run through NetBeans?
> 
>  - Chuck
> 
> 
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR
> OTHERWISE PROPRIETARY MATERIAL and is thus for use only by
> the intended recipient. If you received this in error,
> please contact the sender and delete the e-mail and its
> attachments from all computers.
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail:
> users-help@tomcat.apache.org


      


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message