tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Baunty ruparelia" <hitesh....@gmail.com>
Subject Https & SSL support in Tomcat 5.5
Date Wed, 23 Jul 2008 07:04:57 GMT
Hi,

We configured <connector> node in server.xml file to enable the HTTPS and
SSL support. our server.xml file is in the $CATALINA_BASE. our configuration
is shown below

<Connector maxHttpHeaderSize="8192"
port="80"
maxThreads="150" minSpareThreads="10" maxSpareThreads="20"
enableLookups="false"
redirectPort="443" acceptCount="100"
connectionTimeout="60000" disableUploadTimeout="true"/>

<!-- Define a SSL HTTP/1.1 Connector on port 443 -->
<Connector maxHttpHeaderSize="8192"
port="443"
maxThreads="150" minSpareThreads="10" maxSpareThreads="20"
enableLookups="false" disableUploadTimeout="true"
acceptCount="100" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS"
keystoreFile="conf/keystore.jks"keystorePass="xxxxx"/>

Problem:-
when we are fire the http://localhost into the IE address bar, It not be
transfer to the https://localhost:443 which should be happen, as we are
define the redirect port.
even, when we are extenally supply the https://localhost:443 then also it
would not give our index.jsp, rather than it showing "page not found" error.
but when we specify only https://localhost it automatically transfer the
http://localhost
even. http://localhost:443 is working fine.
In Summary: https and its port combination is not work, other than all
combination work, and showing http://localhost

Please needful help regarding this problem.

Thanks in Advance.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message