tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hassan Schroeder" <hassan.schroe...@gmail.com>
Subject Re: [Same Behavior]Connections timing out even with validation query??
Date Wed, 16 Jul 2008 13:50:45 GMT
On Wed, Jul 16, 2008 at 5:42 AM, Ken Bowen <kbowen@als.com> wrote:

> On Jul 16, 2008, at 8:20 AM, David Smith wrote:
>
>> I don't think "1000*60" is a valid expression for
>> timeBetweenEvictionRunsMillis -- at least I've never tried putting math
>> expressions where an integer constant should be.  It should be set to 60000.

+1 -- that didn't look right to me, either, but I didn't try it.

> All connections are /supposed/ to be closed when the interaction if
> finished, but there still could be one slipping through.

Suggestions: install LambdaProbe, which provides a nice graphical
pool monitor; makes a connection leak *very* obvious.
(<http://www.lambdaprobe.org/>)

Also, change that value above, restart, and tail -f your mysql query
log and tomcat logs together, so you can confirm validation queries
are being sent, and see when they stop showing up in the log.

HTH,
-- 
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message