tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Multiple websites in tomcat
Date Wed, 23 Jul 2008 22:12:10 GMT
Let's go.

Here is the link to my system, which works fine :
http://dev.dev.wissensbank.com/servlets-examples

It goes through Apache, mod_jk, and tomcat5.5.

This is my workers.properties :
workers.tomcat_home=/usr/share/tomcat5.5
workers.java_home=/usr/lib/jvm/java-1.5.0-sun
ps=/
worker.list=ajp13
worker.ajp13.port=8010
worker.ajp13.host=localhost
worker.ajp13.type=ajp13
worker.ajp13.lbfactor=1
worker.loadbalancer.type=lb
worker.loadbalancer.balanced_workers=ajp13


Here are the relevant lines from httpd.conf :

<IfModule mod_jk.c>
   JkMount /servlets-examples ajp13
   JkMount /servlets-examples/* ajp13
</IfModule>

There is also this file (jk.conf), included in httpd.conf when starting :
JkWorkersFile /etc/apache2/workers.properties
JkLogFile /var/log/apache2/mod_jk.log
JkLogLevel debug
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
JkRequestLogFormat "%w %V %T"

All that looks very similar to what you have.
One difference is that my version of mod_jk is 1.2.18.

But when I run this, I get quite different information in my mod_jk.log.
You can see it at this address :
http://dev.dev.wissensbank.com/download/mod_jk.log

It's a log file of just now, after accessing the examples page with the 
link I give at the top.
The difference is, in my case it works.

André

P.S. There are some differences on my system, because I have multiple 
VirtualHosts and more different JkMount that I did not mention above.
But I don't think that it explains why your system is not working, and 
mine is.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message