tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sérgio Vieira Rolanski <ser...@strategos.com.br>
Subject Re: Problem publishing application to debian with tomcat 5.5.17
Date Thu, 10 Jul 2008 15:03:50 GMT
The basewebAcessoLogin.unidade.seqUnidade.value returns an Integer object. The weird thing
is that it works on Windows (netbeans + bundle tomcat), but it doesn't work on Debian. Both
are running Tomcat 5.5.17. From my point of view it should work on both servers without the
need to change anything.

I just made a test, created a converter for SelectOneMenu to converter from String to Integer
and vice-versa. It's now working on both Windows and Debian. But my project currently has
more than 200 web pages. It's an enterprise level web application, many modules, many functions
and may be too many things on it. ;)

This problem started recently, couple of weeks ago the tomcat on Debian server wasn't complaining
about anything, was running just as smooth as tomcat on Windows. It all started after we split
the web project into smaller modules.

Now we have a web project that use several libraries, each library is a module with its own
web pages, java source code for each page and so on.


Konstantin Kolinko wrote:
> Well, looking at the sources...
>
> http://myfaces.apache.org/shared11/myfaces-shared-core/xref/org/apache/myfaces/shared/renderkit/RendererUtils.html#531
> http://myfaces.apache.org/shared11/myfaces-shared-core/xref/org/apache/myfaces/shared/renderkit/RendererUtils.html#504
>
> The RendererUtils.getConvertedStringValue( , Object) method does
> not accept values of selectItem.getValue() that are not instance of
> java.lang.String, and generates that message that you are seeing.
>
> In your code:
>
> value="#{basewebAcessoLogin.unidade.seqUnidade.value}"
>
> Is the value of seqUnidade.value a java.lang.String, or a java.lang.Integer?
> If it is Integer, it may be the cause.
>
>
>
> 2008/7/10 Sérgio Vieira Rolanski <sergio@strategos.com.br>:
>   
>> I converted my jsp file to UTF-8 and set the file.enconding on JAVA_OPTS,
>> but still have the problem. Also another person here tried this on a
>> different computer not using Integer object but String objects instead and
>> it gives the same error. What I find more weird is that it says the value is
>> equal to 1 ("value=1") on the exception's message, but nothing is being set
>> to 1 anywhere on the code.
>>
>> java.lang.IllegalArgumentException: Value is no String
>> (class=java.lang.Integer, value=1) and .......
>>
>> or that has nothing to do with the value I'm setting?
>>
>>     
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>   


Mime
View raw message