tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: JSTL problem in v2.5 web application
Date Fri, 04 Jul 2008 00:50:41 GMT
What version of JSTL jars are you using and what do you have up at the 
top of your jsp declaring the taglibs?  Seems like this is a mix up 
using and older tld with a newer JSTL syntax or mixing versions of 
standard.jar and jstl.jar.

--David

stanlick wrote:
> I just installed the new Eclipse Ganymede and Tomcat 6.x server and created a
> dynamic web app.  I added the JSTL jars to the project and after much
> fussing around trying to get the jars to actually deploy to the WEB-INF/lib
> folder, I am getting this error when trying to use the core tag library c:if
> as follows
>
> <c:if test="${!empty pageContext.session.id}">
> ${pageContext.session.id}
> </c:if>
>
> org.apache.jasper.JasperException: /index.jsp(20,0) According to TLD or
> attribute directive in tag file, attribute test does not accept any
> expressions
>
> This worked fine in previous versions.
>
> Also, any idea why I had to muck around in the Java EE Module Dependencies
> to get the two JSTL jars to actually copy out of the workspace?
>
> Peace,
> Scott
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message