tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nop <nopa...@iplace.at>
Subject RE: i18n deployment
Date Wed, 23 Jul 2008 07:37:24 GMT
Seems like hotmail doesn't like to post xml content, so i post this from
an other account. Sorry for spamming the list!

Hello Chuck,
thank you very much for your help!
I've stopped tomcat, cleaned the directories conf/Catalina/ and
work/Catalina and started tomcat again, but i still get only the welcome
page from the default host displayed.

This is whats inside server.xml:

<?xml version='1.0' encoding='utf-8'?>
 
<Server port="8005" shutdown="SHUTDOWN">

  <Listener className="org.apache.catalina.core.AprLifecycleListener"
SSLEngine="on" />
  <Listener className="org.apache.catalina.core.JasperListener" />
  <Listener
className="org.apache.catalina.mbeans.ServerLifecycleListener" />
  <Listener
className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />

  <GlobalNamingResources>
    <Resource name="UserDatabase" auth="Container"
              type="org.apache.catalina.UserDatabase"
              description="User database that can be updated and saved"

factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
              pathname="conf/tomcat-users.xml" />
  </GlobalNamingResources>

  <Service name="Catalina">
  
    <Connector port="80" protocol="HTTP/1.1" 
               connectionTimeout="20000" 
               URIEncoding="UTF-8"
               redirectPort="8443" />

    <Engine name="Catalina" defaultHost="appname.com">

      <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
             resourceName="UserDatabase"/>
       
      <Host name="appname.com"  appBase="appname_com"
            unpackWARs="true" autoDeploy="false"
            xmlValidation="false" xmlNamespaceAware="false">
      </Host>

      <Host name="appname.de"  appBase="appname_de"
            unpackWARs="true" autoDeploy="false"
            xmlValidation="false" xmlNamespaceAware="false">
      </Host>

    </Engine>
  </Service>
</Server>


content.xml, which is located at META-INF direcoty inside the war file
(myapp.war), follows.
After deployment theres a copy of the file in
catalinahome/conf/Catalina/appname.com/myapp.xml and
catalinahome/conf/Catalina/appname.de/myapp.xml.

<?xml version="1.0" encoding="UTF-8"?>
<Context debug="5" reloadable="true" crossContext="false">

    <Resource   name="jdbc/appname" auth="Container"
type="javax.sql.DataSource"
                maxActive="150" maxIdle="10" maxWait="-1"
                username="user" password="pwd"
driverClassName="com.mysql.jdbc.Driver"
                validationQuery="SELECT 1" testOnBorrow="true" 
                testWhileIdle="true"
timeBetweenEvictionRunsMillis="600000"
                removeAbandoned="true" removeAbandonedTimeout="60"
logAbandoned="true"

url="jdbc:mysql://localhost:3306/appname?useUnicode=true&amp;characterEncoding=utf-8&amp;mysqlEncoding=utf8"/>
</Context>

By the way, i deploy by stopping tomcat, copying the war file into the
appBase directory and starting tomcat again - does this make any
difference than deploying with tomcats manager application?

Thanks again for you help!



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message