tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ramya lekha" <ramyalekh...@gmail.com>
Subject Re: Problem regarding the connector..
Date Thu, 05 Jun 2008 20:23:02 GMT
Hi

I had attached the httpd.conf file along with this mail...
The Directory root is set to usr/abcd-web and our application "testapp" is
under usr/apache/tomcat/webapp.... So when ever the url
spixxl.xxx.com/testapp is called it is searching under usr/abcd-web instead
of usr/apache/tomcat/webapp.... The error in the mod_jk.log file is
displayed below:

[Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] jk_shm.c (471):
Reseting the shared memory for child 6
[Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] jk_shm.c (262):
Duplicated shared memory lock /usr/apache/logs/mod_jk.shm.942337.lock
[Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] mod_jk.c (2730):
Attached shm:/usr/apache/logs/mod_jk.shm.942337 (28672 bytes)
[Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] mod_jk.c (2740):
Initialized mod_jk/1.2.26
[Wed Jun 04 21:04:16 2008] [943458:3223019520] [debug] mod_jk.c (3033):
missing uri map for spixxl.xxx.com:/testapp/test.jsp

And the workers.properties I wrote is :

# Define some properties
workers.tomcat_home=/usr/apache/tomcat
workers.java_home=/usr/opt/java141
ps=/
worker.list=worker1
# Set properties for worker1(ajp13)
worker.worker1.type=ajp13
worker.worker1.host=spixxl.xxx.com
worker.worker1.port=2004
worker.worker1.connection_pool_timeout=600
worker.worker1.socket_keepalive=1
worker.worker1.socket_timeout=60

Do let me know if anything more is needed..

Regards,
Ramya


On 6/5/08, André Warnier <aw@ice-sa.com> wrote:
>
>
>
> Mark Thomas wrote:
>
>>
>> ramya lekha wrote:
>>
>>> Hi
>>>
>>> installed apache and tomcat in my unix systems... and i m trying to
>>> connect
>>> them using the mod_jk... I had set JkMount to the appropriate workers1 in
>>> the httpd.conf file....but still whenever i type the URL the apache is
>>> not
>>> redirecting it to the tomcat... Can anyone let me know where would the
>>> error
>>> be...??
>>>
>>
>> Somewhere in your configuration?
>>
>> The people on this list are good but they aren't psychic ;)
>> You'll need to post the relevant extracts from your configuration files.
>>
>> Taking the words out of my mouth ;-)
> You know ramya, we believe you when you say that you set everything to the
> appropriate workers etc.., we really do. But we'd like to see anyway, just
> in case ;-)
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
View raw message