tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Wick" <sw...@NicholsonKovac.com>
Subject Unable to Start Tomcat 6 with Catalina Base Set
Date Mon, 02 Jun 2008 19:00:38 GMT
> I installed Tomcat 6.0.16 to /usr/local/apache-tomcat-6.0.16 (this is
> my CATALINA_HOME).  Then I made an instance of tomcat at
> /var/www/tomcat-instances/default-tomcat6 (this is my CATALINA_BASE).
> 
> My CATALINA_BASE/bin/startup.sh looks like this:
> 
> 	CATALINA_BASE=/var/www/tomcat-instances/default-tomcat6
> 	export CATALINA_BASE
> 
> 	CATALINA_HOME=/usr/local/apache-tomcat-6.0.16
> 	export CATALINA_HOME
> 
> 	CATALINA_OPTS="-Xms768m -Xmx768m -XX:MaxPermSize=768m"
> 	export CATALINA_OPTS
> 
> 	JAVA_HOME=/usr/local/java
> 	export JAVA_HOME
> 
> 	$CATALINA_HOME/bin/startup.sh
> 
> I am getting the following error in my CATALINA_BASE/logs/catalina.out
> file:
> 
> 	java.lang.ClassNotFoundException:
> org.apache.catalina.startup.Catalina
> 	        at
> java.net.URLClassLoader$1.run(URLClassLoader.java:200)
> 	        at java.security.AccessController.doPrivileged(Native
> Method)
> 	        at
> java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> 	        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> 	        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> 	        at
> org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:215)
> 	        at
> org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:390)
> 
> My CATALINA_BASE contains the following files:
> 
> 	bin
> 	bin/shutdown.sh
> 	bin/startup.sh
> 	conf
> 	conf/Catalina
> 	conf/Catalina/localhost
> 	conf/Catalina/localhost/manager.xml
> 	conf/Catalina/localhost/admin.xml
> 	conf/Catalina/dumbsterdiver.nicholsonkovac.com
> 	conf/Catalina/dumbsterdiver.nicholsonkovac.com/manager.xml
> 	conf/Catalina/dumbsterdiver.nicholsonkovac.com/admin.xml
> 	conf/server.xml
> 	conf/server.xml.1
> 	conf/catalina.policy
> 	conf/catalina.properties
> 	conf/context.xml
> 	conf/logging.properties
> 	conf/web.xml
> 	logs
> 	shared
> 	shared/classes
> 	shared/lib
> 	temp
> 	work
> 
> I am executing CATALINA_BASE/bin/startup.sh as root.  When I execute
> CATALINA_HOME/bin/startup.sh, tomcat starts up fine.
> 
> I tried copying CATALINA_HOME/lib to CATALINA_BASE/lib, and I got the
> same error.
> 
> I really need help with this issue.
> 
Thanks!

> -
> Stephen Wick
> Kansas City, MO  USA

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message