tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ktou Ho <hk...@hotmail.com>
Subject RE: Singleton in Tomcat 6.0 not working
Date Thu, 05 Jun 2008 03:52:35 GMT

Not it doesn't. It is a test class only contains the constructor and the getInstance() method.
 
Thanks
Elwin> From: Chuck.Caldarale@unisys.com> To: users@tomcat.apache.org> Date: Wed,
4 Jun 2008 19:38:09 -0500> Subject: RE: Singleton in Tomcat 6.0 not working> > >
From: ktou Ho [mailto:hktou@hotmail.com]> > Subject: RE: Singleton in Tomcat 6.0 not
working> >> > I print out the counter in the constructor. ( I also using a>
> debugger check, my filter got call twice also).> > Do you have any subclasses of
the class with the singleton? If so, the static initializer (and therefore the constructor)
will be called twice, once for the parent and once for the subclass.> > - Chuck>
> > THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL
and is thus for use only by the intended recipient. If you received this in error, please
contact the sender and delete the e-mail and its attachments from all computers.> >
---------------------------------------------------------------------> To start a new topic,
e-mail: users@tomcat.apache.org> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org>
For additional commands, e-mail: users-help@tomcat.apache.org> 
_________________________________________________________________
Enjoy 5 GB of free, password-protected online storage.
http://www.windowslive.com/skydrive/overview.html?ocid=TXT_TAGLM_WL_Refresh_skydrive_062008
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message