tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Len Popp" <len.p...@gmail.com>
Subject Re: IE cuts URI - Query part off?
Date Mon, 02 Jun 2008 13:00:20 GMT
I don't think the problem will be in the browser. I've used IE 6 a lot
and never seen a problem like that.

Here are some ways you can trace the request to see where it goes wrong:

1. ieHTTPHeaders plug-in for IE to see the request that is being sent

2. Access logs on the server to see the request that is received
(AccessLogValve for Tomcat, and any other web server, firewall and
proxy logs you have)

3. Wireshark on both the client and server ends (and at intermediate
proxies if possible)

-- 
Len


On Mon, Jun 2, 2008 at 3:36 AM, Marcel Ruff <mr@marcelruff.info> wrote:
> Hi,
>
> this is a general URI:
>
>  http://server.xmlBlaster.org:8008/myPath?key=value#myFragment
>
> I have now the problem that the Query part (key=value) is not arriving
> in tomcat.
> Tomcat 6 runs behind Apache 2.2.4.
>
> It works fine for most users but not for one with IE Version 6.0.29000
> Sending
>
>  http://xmlBlaster.org/myPath/x.jsp?key=value
>
> the key=value is not arriving.
>
> Who cuts this off, how can i trace this down?
>
> Is it possible to make a redirect or forward or something else like this:
>
>  http://xmlBlaster.org/X
>
> and having there an index.php which forwards
>
>  http://xmlBlaster.org/myPath/x.jsp?key=value
>
> Thanks for some advice
> Marcel
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message