tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Junaid Arshad ...@comp.leeds.ac.uk>
Subject Re: Problem Running mod_jk with apache2
Date Fri, 20 Jun 2008 10:44:03 GMT

Thanks!

I got this working. I guess the apxs2 that I installed using apt-get was 
for apache2.2. This solved the problem but I am getting errors as:

/Invalid command 'logsJkLogFile', perhaps mis-spelled or defined by a 
module not included in the server configuration/

I guess there is a problem in loading mod_jk. I've pasted mod_jk 
settings part of my httpd.conf  as under...

Any hints as to what might correct this.....

Cheers

Junaid

LoadModule jk_module /usr/lib/apache2/modules/mod_jk.so
# Where to find workers.properties
JkWorkersFile /usr/local/apache2/workers.properties
# Where to put jk
logsJkLogFile /var/log/apache2/mod_jk.log
# Set the jk log level
[debug/error/info]JkLogLevel info
# Select the log format
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
# JkOptions indicate to send SSL KEY SIZE,
JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
# JkRequestLogFormat set the request format
JkRequestLogFormat "%w %V %T"
# Send servlet for context / jsp-examples to worker named worker1
JkMount /jsp-examples worker1
# Send JSPs for context /jsp-examples/* to worker named worker1
JkMount /jsp-examples/* worker1


Rainer Jung wrote:
> Junaid Arshad wrote:
>> Rainer Jung wrote:
>>> Junaid Arshad wrote:
>>>> Hi All,
>>>>
>>>> I've been trying to setup mod_jk1.2.15 with Apache2.0.63 and tomcat 
>>>> 5.5.23. After some hassle I was able to build mod_jk.so and did 
>>>> modify the httpd.conf to say the location of the ".so" and 
>>>> worksers.properties but when I tried to start apache it failed with 
>>>> the following error:
>>>>
>>>> eipvm03:/usr/local/apache2/bin# ./apachectl 
>>>> restart                             Syntax error on line 1081 of 
>>>> /usr/local/apache2/conf/httpd.conf:
>>>> API module structure 'jk_module' in file 
>>>> /usr/lib/apache2/modules/mod_jk.so is garbled - expected signature 
>>>> 41503230 but saw 41503232 - perhaps this is not an Apache module 
>>>> DSO, or was compiled for a different Apache version?
>
> I checked the MODULE_MAGIC_COOKIE values for httpd. 41503230 is for 
> httpd 2.0 and 41503232 is for httpd 2.2. Modules are not binary 
> compatible between those. So it looks you are building for httpd 2.2 
> and using in 2.0. I still expect your apxs2 to be wrong.
>
>>>> Any help will be much appreciated....
>>>
>>> Which steps did you go to produce the mod_jk.so?
>>>
>> I followed steps at http://www.debianhelp.co.uk/apachetomcat.htm
>>
>>> Some hints:
>>>
>>> - don't use 1.2.15. We are at 1.2.26. That won't solve your problem, 
>>> but if you start fresh, don't start with such an old version.
>>>
>>> - configure needs --with-apxs. On some systems, there is an apxs 
>>> file for use with httpd 1.3, and a file apxs2 for use with httpd 
>>> 2.0. You need to ask your supplier of httpd, where the correct apxs 
>>> for the version of httpd you want to use sits. In a default 
>>> installation layout of httpd, it is in the bin directory of the 
>>> httpd installation directory. Most Linuxes though scatter all the 
>>> httpd parts around in the system. You can use "rpm -q --filesbypkg" 
>>> to find out, where rpm contents have been installed to.
>>>
>> I did start fresh with 1.2.26 but didn't work again. I've got apxs2 
>> which I got by "apt-get install" and I guess it would be ok. But, 
>> nothing seems to be working ....:-(
>
> So are you sure, this apxs2 belongs to your version of httpd?
>
> Are you sure, that the file you try to load is the file you built? 
> Have a look ate the LoadModule directive for mod_jk and try to figure 
> out, to which path for the *.so file it points to. Is the file there 
> actually the one you built? The file resulting from the build should 
> be either in the apache-2.0 sub directory of the mod_jk source, or in 
> the .libs subdirectory underneath.
>
> Rainer
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message