tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Problem regarding the connector..
Date Fri, 06 Jun 2008 15:52:20 GMT
ramya,

you say that you attach the logfile, but it is not arriving with this post.
That was the same with your first post, remember ? that's why we were 
telling you that we need more details.
Can you resend, and make sure the logfile is attached ? or else, just 
paste the log messages in your message to the list.

Thanks
André


ramya lekha wrote:
> Hi,
> 
> <!-- Define an AJP 1.3 Connector on port 2004 -->
> <Connector port="2004" enableLookups="false" redirectPort="xxxx"
> protocol="AJP/1.3" />
> 
> whenever I am trying to add the protocol attribute in the connector tag  in
> the server.xml file and start the tomcat server.. its not listening at the
> specified port....
> 
>  And when i make this change
> 
> JkMount /testapp  ajp13
> JkMount /testapp/* ajp13
> 
> or
> <Location /testapp>
>  SetHandler Jakarta-servlet
>  ..
> </Location>
> 
> in the httpd.conf file...but i m still not able to connect to the tomcat
> server
> I am attaching the mod_jk.log file along with this mail so that you can know
> the errors what I get..... Do let me know as to what has to be done....
> 
> Thanks
> Ramya
> 
> 
> On Thu, Jun 5, 2008 at 5:52 PM, André Warnier <aw@ice-sa.com> wrote:
> 
>>
>> ramya lekha wrote:
>>
>>> Hi
>>>
>>> I had attached the httpd.conf file along with this mail...
>>> The Directory root is set to usr/abcd-web and our application "testapp" is
>>> under usr/apache/tomcat/webapp.... So when ever the url
>>> spixxl.xxx.com/testapp is called it is searching under usr/abcd-web
>>> instead
>>> of usr/apache/tomcat/webapp.... The error in the mod_jk.log file is
>>> displayed below:
>>>
>>> [Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] jk_shm.c (471):
>>> Reseting the shared memory for child 6
>>> [Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] jk_shm.c (262):
>>> Duplicated shared memory lock /usr/apache/logs/mod_jk.shm.942337.lock
>>> [Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] mod_jk.c (2730):
>>> Attached shm:/usr/apache/logs/mod_jk.shm.942337 (28672 bytes)
>>> [Wed Jun 04 20:51:44 2008] [943571:3223019520] [debug] mod_jk.c (2740):
>>> Initialized mod_jk/1.2.26
>>> [Wed Jun 04 21:04:16 2008] [943458:3223019520] [debug] mod_jk.c (3033):
>>> missing uri map for spixxl.xxx.com:/testapp/test.jsp
>>>
>>> And the workers.properties I wrote is :
>>>
>>> # Define some properties
>>> workers.tomcat_home=/usr/apache/tomcat
>>> workers.java_home=/usr/opt/java141
>>> ps=/
>>> worker.list=worker1
>>> # Set properties for worker1(ajp13)
>>> worker.worker1.type=ajp13
>>> worker.worker1.host=spixxl.xxx.com
>>> worker.worker1.port=2004
>>> worker.worker1.connection_pool_timeout=600
>>> worker.worker1.socket_keepalive=1
>>> worker.worker1.socket_timeout=60
>>>
>>> Do let me know if anything more is needed..
>>>
>>>
>> Well, yes probably.
>>
>> 1) You should have, in your Apache configuration, some instructions telling
>> Apache which URI's should be handled by mod_jk.
>> Something like
>>
>> JkMount /testapp  ajp13
>> JkMount /testapp/* ajp13
>>
>> or
>> <Location /testapp>
>>  SetHandler Jakarta-servlet
>>  ..
>> </Location>
>>
>>
>> 2) in your spixxl.xxx.com Tomcat server.xml configuration, you should have
>> a <Connector> element referencing port 2004
>> Something like
>> <!-- Define an AJP 1.3 Connector on port 2004 -->
>> <Connector port="2004" enableLookups="false" redirectPort="xxxx"
>> protocol="AJP/1.3" />
>>
>> From the error message you show, it looks like it's the first item above
>> that may be incorrect.
>>
>>> [Wed Jun 04 21:04:16 2008] [943458:3223019520] [debug] mod_jk.c (3033):
>>> missing uri map for spixxl.xxx.com:/testapp/test.jsp
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
> 
> 
> ------------------------------------------------------------------------
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message