tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Klaasse" <Jesse.Klaa...@indicia.nl>
Subject URL encoding problem IIS6 / JK1.2.25 / Tomcat 5.5.20
Date Tue, 24 Jun 2008 07:14:29 GMT
I have recently migrated a production server from IIS5 / Resin 3.0.14 to
IIS6 / JK1.2.25 / Tomcat 5.5.20. Now, there seems to be a problem with
the URL translation from IIS to Tomcat.

I have this file in a webapp, called test[brackets].jsp.
When I try http://localhost:8080/webapp/test[brackets].jsp, everything
is working fine. So Tomcat understands the square brackets (appearing in
the Tomcat access log as test[brackets].jsp).

I have also a plain HTML file, called test[brackets].html.
When I try http://localhost/test[brackets].html, it's also working. IIS
by itself understands the square brackets, too.

Now, we try the whole link through the JK connector:
http://localhost/webapp/test[brackets].jsp
This doesn't work, and results in a 404 error (appearing in both IIS and
Tomcat's log as test%5Bbrackets%5D.jsp, Tomcat with a 404, IIS with a
200).

So, there seems to be SOMETHING wrong with the connector (or the
connector configuration) in combination with special characters. When I
try the same with a file called test.jsp, everything is working fine.

The Connector tag in server.xml doesn't have any of the encoding
attributes specified, so default encoding is used. Furthermore, the
uri_select key hasn't been set for the Isapi Redirector, so I guess
default mode ("proxy") is used.

Anyone? Thanks in advance! Kind regards, Jesse Klaasse.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message