tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gangadhar p <gangadhar.pru...@gmail.com>
Subject Re: Tomcat 6 clustering problem
Date Mon, 02 Jun 2008 21:15:54 GMT

Hi Filip,
 
Thanks for your prompt response.
 
I added an attribute to the ServletContext object in one instance and tried
to access the same attribute in another instance and it returns null.

The <Cluster> (in server.xml) element has the attribute
managerClassName=org.apache.catalina.cluster.session.DeltaManager ? Or
org.apache.catalina.session.PersistentReplicationManager is required to be
set?
 
Do you want to see my server.xml files and code?
 
Thank you again.


Filip Hanik - Dev Lists wrote:
> 
> what does your log say?
> 
> Filip
> 
> gangadhar p wrote:
>> Hi Guys, 
>> The Tomcat 6 documentation
>> (http://tomcat.apache.org/tomcat-6.0-doc/config/cluster.html) says that
>> the
>> Context (ServletContext, right ?) attributes are replicated across
>> cluster
>> members when the below element is added in either
>> <tomcat-home>\conf\server.xml or <tomcat-home>\conf\context.xml file.

>> <Context className="org.apache.catalina.ha.context.ReplicatedContext"/>
>>
>> But actually the ServletContext attributes are not replicated across all
>> other cluster members!!!
>>
>> The added contents in my server.xml is given below:
>>
>> 		<Cluster className="org.apache.catalina.cluster.tcp.SimpleTcpCluster"
>>                 
>> managerClassName="org.apache.catalina.cluster.session.DeltaManager"
>>                  expireSessionsOnShutdown="false"
>>                  useDirtyFlag="true">
>>
>>             <Membership 
>>                
>> className="org.apache.catalina.cluster.mcast.McastService"
>>                 mcastAddr="228.0.0.4"
>>                 mcastPort="45564"
>>                 mcastFrequency="500"
>>                 mcastDropTime="3000"/>
>>
>>             <Receiver 
>>                
>> className="org.apache.catalina.cluster.tcp.ReplicationListener"
>>                 tcpListenAddress="127.0.0.1"
>>                 tcpListenPort="4001"
>>                 tcpSelectorTimeout="100"
>>                 tcpThreadCount="6"/>
>>
>>             <Sender
>>                
>> className="org.apache.catalina.cluster.tcp.ReplicationTransmitter"
>>                 replicationMode="pooled"/>
>>             <Valve
>> className="org.apache.catalina.cluster.tcp.ReplicationValve"
>>                   
>> filter=".*\.gif;.*\.js;.*\.jpg;.*\.htm;.*\.html;.*\.txt;"/>
>> 			<ClusterListener 
>> 				
>> className="org.apache.catalina.cluster.session.ClusterSessionListener"/>
>>
>>         </Cluster>
>> 		<Context path=""
>> docBase="G:\RealNetworks\apache-tomcat-6.0.16\webapps\ROOT"
>> crossContext="true" debug="0" reloadable="true" privileged="true"/>
>>
>> And the added contents in config.xml file is given below:
>>
>> <Context className="org.apache.catalina.ha.context.ReplicatedContext">
>>
>> Any modifications required?
>> Any suggestions would be highly appreciated.
>> Thanks in advance.
>>   
> 
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Tomcat-6-clustering-problem-tp17609817p17610976.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message