tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lists <li...@dankeeley.co.uk>
Subject CPU usage quirk with multiple tomcat instances
Date Fri, 02 May 2008 12:42:18 GMT
Hi,

We have a Tomcat app that is loadbalanced by hardware.  I have 4 boxes
available in our test env, all of which vary slightly but not massively in
spec.

Anyway I moved from 2 tomcat instances on each machine ( listening on
different ports ) down to 1 and I noticed for the same load the cpu
utilisation dropped by 20%.  Interesting, how can this be explained?  Is
this the extra effort in tomcat or something?  Or is it memory related? the
2 instances had 1gb each, and the single one has been given 4gb.  However I
have jprofiled the instance and it has never seemed memory hungry.  Anyway I
suspect even at 2gb for 1 instance it would still be 20% less cpu - i can
always do a run to prove this if people think that necessary..

Another thing i've found is that on one server I have abnormally high CPU
utilisation for the same load.  I've checked the logging levels are all the
same as are the java VM and the VM config settings.  I wonder what else
could cause this?  All i can think is some sort of OS or hardware
malfunction! maybe the CPU cache is duff or something.

Many thanks to any input to my Friday weird-ness!
Dan

________________________________________________
Message sent using UebiMiau 2.7.10



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message