tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hansen, P (Palle)" <Palle.Han...@rabobank.com>
Subject RE: Web Service on Tomcat on Solaris
Date Wed, 07 May 2008 09:06:42 GMT
Hi Thanks for the reply

I got it sorted now, I don't fully understand what went wrong, but here is what I did find
out

My Tomcat is listening on default port 8080, when I created my project in eclipse the wsdl
file was created with a different port (I don't understand why) so I worked in eclipse, it
also worked on my tomcat running windows because it was on the same server as eclipse, once
I shut down eclipse the WS in tomcat stopped working on Windows as well

I changed the port in my wsdl file but it made no difference.

I then copied my java code and deleted the entire project from eclipse, and started a new
one, this time the port in the wdsl file was the correct 8080, I pasted the code back in a
generated the Web Service and it all works now

Palle

-----Original Message-----
From: Rainer Jung [mailto:rainer.jung@kippdata.de]
Sent: 04 May 2008 12:10
To: Tomcat Users List
Subject: Re: Web Service on Tomcat on Solaris

Hi,

Hansen, P (Palle) schrieb:
> Hi All
>
> I'm fairly new to Tomact etc, but I've developed a Web Service in
> Eclipse, and it works great there
>
> I created the War Files and deployed them to Tomcat 5.5 running on
> Windows and everything looks Great
>
> I then installed Tomcat on Unix Solaris 8 And deployed the war files
> there.
>
> This is where the problem starts.
>
> The jsp pages are displayed ok, but as soon as I hit the button that
> will invoke the java class all I get is
>
> exception: java.net.ConnectException: Connection refused

Where s the code running, that gets the exception? Is this some client
side code, or code that runs within Tomcat? What's the exception stack?

Where does this code want to connect to (name or IP address, port) and
how does it get this information (configuration etc.)?

> The same class works on Tomcat running on windows
>
> I've put some debug lines in the class file, and in fact there is a
> debug line at the very beginning and that don't even get executed, so
> I don't think any of the method is being executed
>
> Any help would be appreciated
>
> Thanks
>
> Palle Hansen

Regards,

Rainer

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

_____________________________________________________________

This email (including any attachments to it) is confidential, legally privileged, subject
to copyright and is sent for the personal attention of the intended recipient only. If you
have received this email in error, please advise us immediately and delete it. You are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of
this information is strictly prohibited. Although we have taken reasonable precautions to
ensure no viruses are present in this email, we cannot accept responsibility for any loss
or damage arising from the viruses in this email or attachments. We exclude any liability
for the content of this email, or for the consequences of any actions taken on the basis of
the information provided in this email or its attachments, unless that information is subsequently
confirmed in writing. If this email contains an offer, that should be considered as an invitation
to treat.
_____________________________________________________________

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message