tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Kaupisch" <kaupi...@me.dium.com>
Subject RE: Tomcat Comet Question
Date Wed, 28 May 2008 18:27:14 GMT
Found the problem...the issue that I had was the following: I didn't
realize that the webapp that I was trying to change was using a redirect
servlet in a different project (which didn't implement CometProcessor).
Once I disabled the redirect servlet, things started to work...

So that brings me to my next Comet noob question...the redirect servlet
in this other project extends HttpServlet and only has an init and
service method defined...how do I integrate that with CometProcessor? Do
I still implement CometProcessor and leave the event method empty? I'll
start with trying that first, but wanted to know what people recommend
before I just hack at it...

Thanks

Adam

-----Original Message-----
From: Filip Hanik - Dev Lists [mailto:devlists@hanik.com] 
Sent: Tuesday, May 27, 2008 8:20 PM
To: Tomcat Users List
Subject: Re: Tomcat Comet Question

try the simplest thing first, upgrade to 6.0.16,
in terms of your config, you have tcnative-1.dll in your PATH, but you 
haven't configured the APR connector, you have configured NIO (which 
works for comet) and the regular blocking (which doesn't work for comet)


Filip


Adam Kaupisch wrote:
> I am having trouble getting Comet to work and was hoping someone knows
> what my problem is...
>
>  
>
> I am running 6.0.13 on windows XP (yea, I need to change to linux, I
> know)...anyway, I went through getting the APR setup and I believe I
> have done so...based on when I start tomcat up, I get this message:
>
> May 27, 2008 2:45:23 PM org.apache.catalina.core.AprLifecycleListener
> init
>
> INFO: Loaded Apache Tomcat Native library 1.1.12.
>
> May 27, 2008 2:45:23 PM org.apache.catalina.core.AprLifecycleListener
> init
>
> INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
> [false], random [true].
>
> May 27, 2008 2:45:24 PM org.apache.coyote.http11.Http11NioProtocol
init
>
> INFO: Initializing Coyote HTTP/1.1 on http-8080
>
> May 27, 2008 2:45:24 PM org.apache.coyote.http11.Http11Protocol init
>
> INFO: Initializing Coyote HTTP/1.1 on http-8081
>
> May 27, 2008 2:45:24 PM org.apache.coyote.http11.Http11NioProtocol
init
>
> INFO: Initializing Coyote HTTP/1.1 on http-8443
>
> May 27, 2008 2:45:24 PM org.apache.catalina.startup.Catalina load
>
> INFO: Initialization processed in 1741 ms
>
>  
>
> I have a servlet that sits behind a filter. When I try to access it,
it
> calls doFilter(...) instead of doFilterEvent(...). Is there something
> I'm missing in my config? I'm poking around blindly, so I'd be happy
if
> anyone can point me in the right direction.
>
>  
>
> Thanks
>
>  
>
> Adam
>
>
>   
>
------------------------------------------------------------------------
>
> No virus found in this incoming message.
> Checked by AVG. 
> Version: 7.5.524 / Virus Database: 269.24.1/1468 - Release Date:
5/26/2008 3:23 PM
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message