tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Khurram H Khan <kk...@arpatech.com>
Subject [Fwd: Tomcat manager]
Date Wed, 14 May 2008 06:38:15 GMT
Hello everyone,

I have sent an email before regarding tomcat manager. And the issue was 
that I could not use the same username and password to start/stop a 
webapp using http://IP_ADDRESS/manager/stop?path=/My_WebAp . And it 
keeps popping up an input box for username and password. I have the same 
username and password for the admin webapp and it works. But this 
username and password does not work for the manager webapp even though I 
have the same username and password. Let me give you the content of my 
tomcat-users.xml which are the following:

<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
  <role rolename="tomcat"/>
  <role rolename="role1"/>
  <role rolename="manager"/>
  <role rolename="admin"/>
  <user username="some_user" password="some_user123" roles="tomcat"/>
  <user username="some_user" password="some_user123" roles="role1"/>
  <user username="some_user" password="some_user123" roles="tomcat,role1"/>
  <user username="some_user" password="some_user123" roles="admin,manager"/>
</tomcat-users>

Username some_user and password some_user123 work for admin but tomcat 
keeps popping up an input box for the manager. Any idea why is this 
case? What am I doing wrong here?

Regards
Khurram

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message