tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Cox" <shakahsha...@gmail.com>
Subject Re: Tomcat takes 2 hours to start
Date Wed, 30 Apr 2008 11:34:44 GMT
>> >> when i start the server in normal mode with command
>> >> " /opt/tomcat/in/catalina.sh  run"
>> >> it starts in almost 2 hours.

FWIW, your log excerpt shows a 2-minute delay, not a 2-hour delay as your
originally reported.

In any case, re your question on starting via "truss", it should be as
simple as the following:
  truss /opt/tomcat/in/catalina.sh run

(though I assume you really meant "/opt/tomcat/*b*in/catalina.sh run")

If you tail the Tomcat log and then start tomcat via truss (as shown above)
you'll hopefully see something valuable in the truss output when you see the
pause in the Tomcat logging.


On Wed, Apr 30, 2008 at 2:44 AM, jitesh sharma <jiteshdevelopment@gmail.com>
wrote:

>
> hello,
>
> Tomcat logs when it starts :
>
> Apr 30, 2008 12:08:32 PM org.apache.catalina.core.AprLifecycleListen er
> lifecycleEvent
> INFO: The Apache Tomcat Native library which allows optimal performance in
> produ ction environments was not found on the java.library.path:
> /usr/jdk/instances/jd
>
> k1.5.0/jre/lib/i386/client:/usr/jdk/instances/jdk1.5.0/jre/lib/i386:/usr/jdk/ins
> tances/jdk1.5.0/jre/../lib/i386:/usr/lib
> Apr 30, 2008 12:08:33 PM org.apache.coyote.http11.Http11BaseProtocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> Apr 30, 2008 12:08:33 PM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 3929 ms
> Apr 30, 2008 12:08:34 PM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Apr 30, 2008 12:08:34 PM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/5.5.26
> Apr 30, 2008 12:08:34 PM org.apache.catalina.core.StandardHost start
> INFO: XML validation disabled
> Apr 30, 2008 12:08:54 PM java.util.prefs.FileSystemPreferences$7 run
> WARNING: Prefs file removed in background /.java/.userPrefs/prefs.xml
> Apr 30, 2008 12:08:54 PM java.util.prefs.FileSystemPreferences$7 run
> WARNING: Prefs file removed in background
> /etc/.java/.systemPrefs/prefs.xml
>
> -------------------------------------------------------------------------------
> After this output it goes for a long break  and then print
>
> -------------------------------------------------------------------------------
>
> Apr 30, 2008 12:10:38 PM org.apache.coyote.http11.Http11BaseProtocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> Apr 30, 2008 12:10:39 PM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> Apr 30, 2008 12:10:39 PM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/59  config=null
> Apr 30, 2008 12:10:39 PM org.apache.catalina.storeconfig.StoreLoader load
> INFO: Find registry server-registry.xml at classpath resource
> Apr 30, 2008 12:10:39 PM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 125914 ms
>
>
> Thanks
> jitesh
>
>
> mgainty wrote:
> >
> > It seems you are perhaps using different startup parameters?
> > We could provide a more comprehensive answer if you display Tomcat log
> > for the startup configuration experiencing the long delay
> >
> > Thanks
> > Martin--
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/Tomcat-takes-2-hours-to-start-tp16953495p16976673.html
> Sent from the Tomcat - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message