tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Fisher <dfis...@jmlafferty.com>
Subject Re: LD_LIBRARY_PATH issue
Date Fri, 11 Apr 2008 04:07:14 GMT
Hi,

Look carefully at the LD_LIBRARY_PATH man page.

At least under Solaris, if you are sudo'ing in some way to root then  
it will not reset LD_LIBRARY_PATH. This is a security measure.

You may need to configure the root to include these libraries.

This was 7 years ago that we encountered this situation, so I can't  
give you detail.

I hope this sets you on the right path.

Regards,
Dave

On Apr 10, 2008, at 10:40 PM, Geofrey Rainey wrote:

> Hello,
>
>
>
> I am setting up Tomcat to connect to an Oracle RAC cluster using the
> Oracle OCI driver.
>
>
>
> The documentation I have read says to configure LD_LIBRARY_PATH under
> Linux topoint
>
> to the Oracle OCI library file directories, but no matter where I set
> LD_LIBRARY_PATH it
>
> does not get honored.
>
> I am getting a JVM crash and a trace file containing the environment
> settings shows that
>
> LD_LIBRARY_PATH is always set to the library directories under
> $JAVA_HOME.
>
>
>
> How do I set the LD_LIBRARY_PATH for Tomcat?
>
>
>
> Regards,
>
> Geofrey Rainey.
>
> ==========================================================
> For more information on the Television New Zealand Group, visit us
> online at tvnz.co.nz
> ==========================================================
> CAUTION:  This e-mail and any attachment(s) contain information that
> is intended to be read only by the named recipient(s).  This  
> information
> is not to be used or stored by any other person and/or organisation.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message