tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: parsing of .jsp not functional
Date Tue, 01 Apr 2008 12:50:50 GMT
It would seem your request for file.jsp is not being routed through 
mod_jk and is hitting a local file.jsp in your httpd site.  Where is the 
errant file.jsp located?  Does tomcat show any log messages for the 
moment in time when page is requested?  Anything in your httpd logs 
regarding the request?

--David

Andre Hübner wrote:
> Hi List,
>
> i have a Problem with parsing .jsp Files using Apache/mod_jk
>
> My Setup: Apache 2.2.8 mod_jk 1.2.26  Tomcat 5.5.26 on Suse Linux 10.1
>
> Tomcat/Apache is up and running, on TomcatPort i can parse .jsp files
>
> domain.com:8080/file.jsp is working but domain.com/file.jsp is not and 
> i dont know how.
>
> This is my mod_jk.conf
>
> LoadModule    jk_module  /usr/lib/apache/mod_jk.so
> JkWorkersFile "/usr/share/tomcat5/conf/workers.properties"
> JkLogFile "/usr/share/tomcat5/logs/mod_jk.log"
> JkLogLevel info
> JKMount /*.jsp ajp13
> JKMount /*.srv ajp13
> JKMount /admin/* ajp13
> JKMount /manager/* ajp13
>
> This is my workers.properties:
>
>
> workers.tomcat_home=/usr/share/tomcat5/
> workers.java_home=/usr/lib/jvm/java
> ps=/
>
>
> worker.list=ajp13, ajp14
> worker.ajp13.port=8009
> worker.ajp13.host=localhost
> worker.ajp13.type=ajp13
> worker.ajp13.lbfactor=1
>
> #worker.ajp14.port=8010
> #worker.ajp14.host=localhost
> #worker.ajp14.type=ajp14
> #worker.ajp14.secretkey=secret
> #worker.ajp14.credentials=myveryrandomentropy
> #worker.ajp14.lbfactor=1
>
> worker.loadbalancer.type=lb
> worker.loadbalancer.balanced_workers=ajp13
> worker.inprocess.type=jni
> worker.inprocess.class_path=$(workers.tomcat_home)$(ps)lib$(ps)tomcat.jar
> worker.inprocess.cmd_line=start
> worker.inprocess.jvm_lib=$(workers.java_home)$(ps)jre$(ps)bin$(ps)classic$(ps)jvm.dll

>
> worker.inprocess.stdout=$(workers.tomcat_home)$(ps)logs$(ps)inprocess.stdout 
>
> worker.inprocess.stderr=$(workers.tomcat_home)$(ps)logs$(ps)inprocess.stderr 
>
>
> System comes up with no errors. But i see sourcecode when requesting 
> .jps Files over Apache.
>
> Unfortunately, i do not find the mistake. There are some warnings in 
> mod_jk.log
>
> [Tue Apr 01 09:03:23.826 2008] [32636:3081734336] [warn] 
> map_uri_to_worker::jk_uri_worker_map.c (608): Uri * is invalid. Uri 
> must start with /
> [Tue Apr 01 09:04:07.877 2008] [14898:3081734336] [warn] 
> map_uri_to_worker::jk_uri_worker_map.c (608): Uri * is invalid. Uri 
> must start with /
>
> What could be wrong in my case? Is there any help?
>
> Thank you
> Andre
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message