tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Hübner <andre.hueb...@gmx.de>
Subject Error invoking operation addEnvironment
Date Thu, 03 Apr 2008 14:39:20 GMT
Hi List,

me again, my last error could be solved. I hope this case too.
I have a Problem in tomcat-admin . I got error 500 when addmin Environment 
Entries. Path is:
Tomcat-->Service-->Host --> Context-->Resources-->Environment Entries
When i choose "create new env antry" i got error 500.
Webpage says:

HTTP Status 500 - Error invoking operation addEnvironment

--------------------------------------------------------------------------------

type Status report

message Error invoking operation addEnvironment

description The server encountered an internal error (Error invoking 
operation addEnvironment) that prevented it from fulfilling this request.


--------------------------------------------------------------------------------

Apache Tomcat/5.5.26



localhost_access.log shows the 500er: "POST /admin/resources/saveEnvEntry.do 
HTTP/1.1" 500 1117

admin.log says:

SCHWERWIEGEND: action: Error invoking operation addEnvironment
javax.management.InstanceNotFoundException: 
Catalina:type=NamingResources,resourcetype=Context,path=/mycontext,host=localhost
        at 
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(Unknown 
Source)
        at 
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(Unknown Source)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(Unknown Source)
        at 
org.apache.webapp.admin.resources.SaveEnvEntryAction.execute(SaveEnvEntryAction.java:155)
        at 
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        at 
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
        at 
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at 
org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at 
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at 
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at 
org.apache.webapp.admin.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:123)
        at 
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at 
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at 
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at 
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
        at 
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
        at 
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at 
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at 
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:548)
        at 
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at 
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
        at 
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:874)
        at 
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
        at 
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
        at 
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
        at 
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
        at java.lang.Thread.run(Unknown Source)

InstanceNotFoundException? What is missing? It is a typical installation of 
current tomcat 5.5.26 download.
Is this correct? Most folders in server/webapps/admin are empty, but this is 
just like in downloaded package.
http://tomcat.apache.org/download-55.cgi
http://apache.easy-webs.de/tomcat/tomcat-5/v5.5.26/bin/apache-tomcat-5.5.26-admin.tar.gz

Dont know what to do now. ;(  Hope there is some help.

Thank you
Andre 


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message