tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Vassallo" <>
Subject RE: building mod_jk failing
Date Tue, 11 Mar 2008 08:17:12 GMT
Hello Rainer,

Thank you.

I have deleted my Apache and connector, re-dlded and rebuilt from source.
Same issue. I am attaching a full output for reference.

I am using httpd-2.2.8, but the connector only has sub-folders for 1.3 and
2.0. Could this be an issue?


-----Original Message-----
From: Rainer Jung [] 
Sent: 10 March 2008 21:51
To: Tomcat Users List
Subject: Re: building mod_jk failing

Hi Justin,

Justin Vassallo schrieb:
> Thank you that helped. I got gnumake installed and configure worked fine.
> (had to chmod 700 configure and scripts/build/

No, I think you are still using the wrong source download. In the tar.gz 
download of mod_jk 1.2.26 configure is already executable.

> Now getting this warning, otherwise .so being created ok:
> Warning!  dlname not found in
> /native/apache-2.0/

I did the build myself too on Solaris 10 x86. I get no such warning.

My .la file conta9ins a dlname:

myhost% cat apache-2.0/
# - a libtool library file
# Generated by - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 
# Please DO NOT delete this file!
# It is necessary for linking the library.

# The name that we can dlopen(3).

> However, apache is not liking it...
> httpd: Syntax error on line 412 of
> /local/apache/apache2.2.8/conf/httpd.conf: Cannot load
> /local/apache/apache2.2.8/modules/ into server: httpd:
> fatal: /local/apache/apache2.2.8/modules/ wrong ELF data format:

It does load my file and the file command tells me, that m module is a

myhost% file apache-2.0/
apache-2.0/   ELF 32-bit LSB dynamic lib 80386 Version 1, 
dynamically linked, not stripped

I first build httpd with

./configure --with-included-apr --prefix=/my/install/dir --enable-so 
--enable-modules=all --enable-mods-shared=all

Before calling configure I set the env var MAKE to gmake.

After building and installing Apache httpd, I added the lib directory of 
httpd and /usr/sfw/lib to LD_LIBRARY_PATH:


and then I do

./configure --with-apxs=/my/install/dir/bin/apxs

inside the mod_jk native directory and then gmake and gmake install. 
That's it. No errors.

> Thanks - j
> PS - it was Re since I had posted this before I became a user, and
> once I joined



> -----Original Message-----
> From: Rainer Jung [] 
> Sent: 10 March 2008 17:53
> To: Tomcat Users List
> Subject: Re: building mod_jk failing
> Justin Vassallo wrote:
>> Hello,
>> I am trying to build mod_jk on Solaris 10 x86, which unfortunately is not
>> available in binary form.
>> I dlded Apache source and built using:
>>      $ PATH=$PATH:/usr/sfw/bin:/usr/ccs/bin
>>      $ export PATH SH_LIBS
>>      $ ./configure --with-included-apr
>> --prefix=/usr/local/apache/httpd-2.2.8 --enable-so --enable-mods
> -shared=ssl
>> --enable-ssl --enable-module=rewrite --enable-shared=rewrite
>> I then dlded mod_jk source, cd native, then tried to build using the apxs
>> from the Apache i just built from source. I am getting a general error
> which
>> is not helping me to identify the problem.
>> Where can i look to get more information? thanks
>> # ./configure --with-apxs=/local/apache/apache2.2.8/bin/apxs
>> : bad interpreter: No such file or directory
> Not sure, why your mail subject starts with "Re:", I couldn't find any 
> previous mails in this thread.
> configure is a shell script. From the error I would guess, that you 
> downloaded the zip source and not the tarball format. The zip file 
> contains DOS files, so configure and many other files have DOS line 
> endings and using those shell scripts gives an error, because /bin/sh^M 
> is not an existing shell.
> If I'm right about the zip download, simply choose the .tar.gz download, 
> which should work. Are we talking about mod_jk 1.2.26?
> Please also make sure, that you are using the make/gmake in /usr/sfw/bin 
> and not the Solaris make in /usr/ccs/bin.
> Regards,
> Rainer

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message