tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neha Agrawal" <nehav...@gmail.com>
Subject Problem with Tomcat5.5.25 when configured for JSVC
Date Fri, 15 Feb 2008 20:30:28 GMT
Hello
         I configured tomcat 5.5.25 with native libraries (openssl and APR)
for ports 8180 (http) and 8443(HTTPS) on
Linux 2.6.22.9 #1 SMP  x86_64
This is Intel Quad Core Zeon machine 64 bit
The OS is debian for amd64
APR 1.2.7
Open-ssl 0.9.7k

java -version gives the following output
   java version "1.5.0_10"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
     Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_10-b03, mixed mode)

Also i compiled Openssl with -fPIC option

Everything worked fine with Tomcat , but when i configured JSVC tomcat
behaves weird..
it started just once (Just after the install)
everything worked fine
but when i restart tomcat i only get the following in catalina.out

Feb 15, 2008 12:23:41 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8180

no errors: even in the debug/verbose mode..

if i again restart tomcat , the earlier started process just results i nthe
following line in catalina.out
jsvc.exec error: Service exit with a return value of 143

Although every time, i kill the 2 processes of tomcat (started because of
JSVC)

any light is appreciated as i am into this problem for a week now...

thanks
 Neha Agrawal

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message