tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tommy Peterson <stpete...@hotmail.com>
Subject mod_jk/apache+tomcat/400 bad request
Date Wed, 20 Feb 2008 18:48:02 GMT

I just set up Tomcat to talk to Apache for a Java app. I am using virtual hosting with mod_jk.
In my Apache config files I have the following:
JkMount /thedirectory/*.jsp ajp13
JkMount /*/images/* ajp13

However, I am getting a 400 error. The page is just blank. 

The directory on Tomcat is mainly the following:
/webapps/thedirectory/
/webapps/thedirectory/images/
/webapps/thedirectory/subdirectory/

I need all the files in the /webapps/thedirectory/ to be served by Tomcat. I did have in my
Apache configuration:
JkMount /thedirectory/*.jsp ajp13
JkMount /*/servlet/* ajp13

I also tried 
JkMount /thedirectory/*.jsp ajp13

JkMount /thedirectory/images/* ajp13

JkMount /thedirectory/subdirectory/* ajp13

Neither worked. I got the same 400 error in the apache access.log. 

Incidentally, this came about after I continually got a 404 Access Denied error when trying
to access this directory. So I put an index.html file in the /thedirectory/ folder and redirected
it to login.jsp, which is the main page for the Java application that Tomcat is suppose to
handle. So the index.html page is found and it redirects to the login.jsp. The login.jsp is
where the 400 error comes into the scene.

Any ideas? 

Thanks.

_________________________________________________________________
Helping your favorite cause is as easy as instant messaging. You IM, we give.
http://im.live.com/Messenger/IM/Home/?source=text_hotmail_join
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message