tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "美国空间" <kaka...@gmakj.com>
Subject Fwd: Status 404 in tomcat
Date Sat, 02 Feb 2008 05:54:34 GMT
Hello,
I have installed tomcat in my WHM (WHM -> cPanel -> Manage plugins -> click
on Addon Modules tomcat ).

The tomcat work..
When I tried the "nmap 209.62.89.18" command line, the output is:
……
80/tcp open http
8009/tcp open ajp13
8080/tcp open http-proxy
……

And it can run jsp pages with http://uskongjian.gmakj.com:8080
However, I installed servlets to my virtualhost (WHM -> Account Functions ->
Install Servlets).

After that, the virtualhost configure in /etc/httpd/conf/httpd.conf is
LoadModule jk_module libexec/mod_jk.so
<VirtualHost 209.62.89.18:80>
ServerName gmakj.lw173.net
ServerAlias www.gmakj.lw173.net
ServerAdmin webmaster@gmakj.lw173.net
DocumentRoot /home/gmakjlw/public_html
<IfModule mod_suphp.c>
suPHP_UserGroup gmakjlw gmakjlw
</IfModule>
<IfModule !mod_disable_suexec.c>
User gmakjlw
Group gmakjlw
</IfModule>
BytesLog /usr/local/apache/domlogs/gmakj.lw173.net-bytes_log
CustomLog /usr/local/apache/domlogs/gmakj.lw173.net combined
ScriptAlias /cgi-bin/ /home/gmakjlw/public_html/cgi-bin/
<IfModule mod_jk.c>
JkMount /*.jsp ajp13
JkMount /servlet/* ajp13
JkMount /servlets/* ajp13
</IfModule>
</VirtualHost>

And then, I add the following lines in
/usr/local/jakarta/tomcat/conf/server.xml

       <Host name="gmakj.lw173.net" appBase="/home/gmakjlw/public_html">

          <Context path="" reloadable="true"
docBase="/home/gmakjlw/public_html" debug="1"/>

          <Context path="/manager" debug="0" privileged="true"

              docBase="/usr/local/jakarta/tomcat/server/webapps/manager">

                <Valve className="org.apache.catalina.valves.RemoteAddrValve
">

          </Context>

       </Host>
However, when I opened the URL http://gmakj.lw173.net, the browser is ending
up with the following error:

type Status report
message /index.jsp
description The requested resource (/index.jsp) is not available.

I tried to uncomment the following lines in
/usr/local/Jakarta/tomcat/conf/web.xml to turn on the invoker servlet:
<servlet>
<servlet-name>invoker</servlet-name>
<servlet-class>
org.apache.catalina.servlets.InvokerServlet
</servlet-class>
<init-param>
<param-name>debug</param-name>
<param-value>0</param-value>
</init-param>
<load-on-startup>2</load-on-startup>
</servlet>
<servlet-mapping>
<servlet-name>invoker</servlet-name>
<url-pattern>/servlet/*</url-pattern>
<servlet-mapping>

After that, I restarted the tomcat and retried to open the same URL .
However, I got the same error.
Can someone to tell me why this situation appear, please?
Thanks and Regards
Charles
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message