tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <>
Subject Re: New jsp not being read
Date Thu, 17 Jan 2008 16:34:34 GMT
I see this most often when the jsp is on a remote server and the clocks 
are out of sync between my desktop system and the server.  Check to be 
sure the clocks are in sync if tomcat is on a remote system and transfer 
the jsp again.  You may want to also consider cleaning out tomcat's work 
directory where compiled jsps are stored at least once whether the clock 
was at fault or not.


Bob Riaz wrote:

>Hi all,
>Here is my environment:
>Eclipse Europa
>Tomcat 5.5
>Windows XP Pro
>My application goes like this:
> request --> servletA --> form.jsp -(post)-> servletB
>My problem is this: when I make a change to form.jsp, this change is not
>reflected in the jsp that gets displayed. An older version of the jsp is
>displayed. I have checked path specified in my servlet to make sure it's
>poitning to the right jsp. In fact, the version that's displayed doesn't
>exist in any of my folders, so I'm not sure where this form would be coming
>from. I've had this result using IE and Firefox. I thought it might be an
>Europa issue, so i tried running the app on Eclipse 3.2 - same result.
>Cleaning and rebuilding the project makes no difference. Also, it doesn't
>seem possible anymore make a change to the servlet, and have it hot
>deployed. I don't get a message from Tomcat saying it couldn't hot deploy,
>but in order to make the modified version of the servlet current I need to
>do a Clean/Rebuild of the project.
>Everybody's thoughts on this would be greatly appreciated!!
>To start a new topic, e-mail:
>To unsubscribe, e-mail:
>For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message