tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Traut <tr...@gmx.de>
Subject Re: tc-native-1.1.12 fails to configure on Redhat EL4 x86_64 (... command not found)
Date Fri, 04 Jan 2008 13:59:07 GMT
Hi Rainer :)

Rainer Jung schrieb:
> Hi Rainer,
> 
> I can reproduce on Solaris.
> 
> The first problem should be fixed by:
> 
> --- configure.orig      2007-12-21 15:06:53.000000000 +0100
> +++ configure   2008-01-04 14:16:13.000000000 +0100
...

> 
> --- build/tcnative.m4.orig      2008-01-04 14:18:10.000000000 +0100
> +++ build/tcnative.m4   2008-01-04 14:16:05.000000000 +0100
...

First problem is fixed with your patch.

Second seems not; I'm no expert with this build stuff, here's what I did:
- applied the second patch to tcnative.m4

- then:

# sh buildconf --with-apr=/usr/src/httpd-2.2.4

Looking for apr source in /usr/src/httpd-2.2.4
Creating configure ...
Generating 'make' outputs ...
buildconf: line 76: /usr/src/httpd-2.2.4/build/gen-build.py: Datei oder 
Verzeichnis nicht gefunden
rebuilding rpm spec file

- am I doing sth wrong here?

- again:

# ./configure --with-apr=/usr/local/apache2/ 
--with-ssl=/usr/include/openssl/

- config.log:
configure:3522: gcc -o conftest -g -O2 -I/usr/include/openssl/include 
conftest.c  -L/usr/include/openssl/lib 
--Wl,-rpath,/usr/include/openssl/lib -lssl -lcrypto >&5
cc1: error: unrecognized command line option 
"-fWl,-rpath,/usr/include/openssl/lib"
configure:3525: $? = 1
configure: program exited with status 1

Thx
Rainer

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message