tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <>
Subject Re: Confusion between docs and server.xml
Date Tue, 01 Jan 2008 15:38:38 GMT
gb1071nx wrote:
> Just got through reading docs and xml comments and thought I'd point out
> something (minor). 
Thanks for the feedback.

> Suggested changes to the documentation (jasper-howto.html) 
> [1] Is 'reloading' a deprecated attribute?  If so, it should be removed
> from the docs.
It has been removed.

> [2] The 'development' attribute should state "every
> modificationTestInterval seconds" (or some such description), instead of
> "on every access".

> [3] The 'modificationTestInterval' attribute should explain it's only
> used when development=true (to distinguish it from 'checkInterval')

> [4] 'checkInterval' appears to have the wrong default value (is it 300
> or 0?)
It should be zero (and has been changed).

> For both the jasper-howto and the comments:
> [5] Is the exclusion of "...(and its dependent files)..." from the
> description of checkInterval deliberate?  If the checks are the same
> regardless of 'development' setting, then I think it should be described
> the same in both 'interval' parameters. Which leads me to...
The exclusion isn't deliberate. I have added it to both to make it clear
how it works.

> [6] This is totally an internals question, so feel free to flame someone
> who doesn't contribute code, but:  couldn't modificationTestInterval and
> checkInterval be merged into a single attribute?  I'm genuinely curious
> to know why it would be "bad" to do so.
They could, but keeping them separate allows simpler switching from
development to production where you almost certainly want different values
for these intervals.

I have also:
- arranged the parameters in both locations in alphabetical order
- added the following parameters missing from one or both locations
  - displaySourceFragment
  - dumpSmap
  - engineOptionsClass
  - suppressSmap
  - xpoweredBy
- removed the sendErrorToClient option that had no code to actually it (and
appears to have been this way for years)
- fixed a few typos

Thanks again for the feedback.


To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message