tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Re: Invalid Keystore Format Exception
Date Wed, 30 Jan 2008 17:23:07 GMT
Glad that your problem is solved :)

++Vamsi

On Jan 30, 2008 10:38 PM, Ole Ersoy <ole.ersoy@gmail.com> wrote:

> OK - Looks like it's an IcedTea thing.  I installed JDK 1.6, regenerated
> the key, and now it works fine.
>
> Thanks again for all the helpful suggestions,
> - Ole
>
>
>
> Vamsavardhana Reddy wrote:
> > Seems strange.  Can you send a keystore file that you generated along
> with
> > the passwords you used for the keystore as well as the key (you can
> generate
> > one with password "secret" say)?  May be I can investigate if there is
> > something wrong with the keystore.  Also, what JDK/JVM are you using?
> >
> > ++Vamsi
> >
> > On Jan 30, 2008 8:12 PM, Ole Ersoy <ole.ersoy@gmail.com> wrote:
> >
> >> Hi Vamsi,
> >>
> >> I tried:
> >> $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA -storetype JKS
> >>
> >> Thanks for the suggestion though,
> >> - Ole
> >>
> >>
> >>
> >> Vamsavardhana Reddy wrote:
> >>> May be you should use the "-storetype JKS" to be sure of the format in
> >> which
> >>> the keystore is generated.
> >>>
> >>> ++Vamsi
> >>>
> >>> On Jan 30, 2008 11:11 AM, Ole Ersoy <ole.ersoy@gmail.com> wrote:
> >>>
> >>>> Hi,
> >>>>
> >>>> I'm trying to get SSL working real quick for some experiments, and I
> >> did
> >>>> this:
> >>>>
> >>>> $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA
> >>>>
> >>>> Answered the questions, got .keystore to appear in my home directory
> >> and
> >>>> then I uncommented the SSL Connector element in server.xml and filled
> >> out
> >>>> the keystoreFile and keystorePass attributes.
> >>>>
> >>>> Now I get this exception:
> >>>>
> >>>> Jan 29, 2008 11:27:38 PM org.apache.coyote.http11.Http11Protocol init
> >>>> SEVERE: Error initializing endpoint
> >>>> java.io.IOException: Invalid keystore format
> >>>>        at sun.security.provider.JavaKeyStore.engineLoad(
> >> JavaKeyStore.java
> >>>> :651)
> >>>>        at sun.security.provider.JavaKeyStore$JKS.engineLoad(
> >>>> JavaKeyStore.java:56)
> >>>>        at java.security.KeyStore.load(KeyStore.java:1202)
> >>>>        at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(
> >>>> JSSESocketFactory.java:319)
> >>>>        at
> >> org.apache.tomcat.util.net.jsse.JSSESocketFactory.getTrustStore(
> >>>> JSSESocketFactory.java:293)
> >>>>        at
> >>>> org.apache.tomcat.util.net.jsse.JSSESocketFactory.getTrustManagers(
> >>>> JSSESocketFactory.java:444)
> >>>>        at org.apache.tomcat.util.net.jsse.JSSESocketFactory.init(
> >>>> JSSESocketFactory.java:378)
> >>>>        at
> >> org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(
> >>>> JSSESocketFactory.java:125)
> >>>>
> >>>>
> >>>> Anyone know why this is happening?  I tried regenerating a few times
> >> but
> >>>> hte results are still the same.
> >>>>
> >>>> Thanks,
> >>>> - Ole
> >>>>
> >>>> ---------------------------------------------------------------------
> >>>> To start a new topic, e-mail: users@tomcat.apache.org
> >>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> >>>> For additional commands, e-mail: users-help@tomcat.apache.org
> >>>>
> >>>>
> >> ---------------------------------------------------------------------
> >> To start a new topic, e-mail: users@tomcat.apache.org
> >> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> >> For additional commands, e-mail: users-help@tomcat.apache.org
> >>
> >>
> >
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message