tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raúl García <rgar...@emovilia.com>
Subject RE: Tomcat 6 - Cluster error.
Date Fri, 18 Jan 2008 10:23:27 GMT
Hi Filip, 

Thank you for that suggestion. We are going to try it now.

On the other side, if You want to reproduce the error:

We have used a server here configured with the same config.xml files.
To force it to the "crash" we send a high amount of "login" request (Those
that creates a new session), for a long time. Not always, but this can
reproduce the error without having to wait 12 days.

At the moment, we tried once the new keepAliveCount="0", and both nodes
worked perfectly during the "experiment" (45 min, 11.000 hits).

It will be a pleasure that you get the debug error, let me know anything
more you need.

Thank you for the response.

We will see the real results in 13 days, I'll update.

Best Regards
Raúl.

-----Mensaje original-----
De: Filip Hanik - Dev Lists [mailto:devlists@hanik.com] 
Enviado el: jueves, 17 de enero de 2008 19:01
Para: Tomcat Users List
Asunto: Re: Tomcat 6 - Cluster error.

already replied to your old thread

ok, it looks like you might have ended up with a rogue socket,
and what happens is that any message sent to that socket just gets lost 
in the ether, since it doesn't have any interest ops.
There is a workaround for this, turn off keep alives all together, or 
implement a keep alive timeout

Option 1 - no keep alives at all

<Transport 
className="org.apache.catalina.tribes.transport.nio.PooledParallelSender"
          timeout="60000"
          keepAliveCount="0"/>

Option 2 - implement a keep alive timeout

<Transport 
className="org.apache.catalina.tribes.transport.nio.PooledParallelSender"
          timeout="60000"
          keepAliveTime="120000"/>

or make a combination of both values

either option should work for you.

On a side note, I'm interested if the scenario you run into is 
reproducible, it keeps happening over and over again, then if possible, 
I'd like to get some debug logs from you

Filip




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message