tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Randeep Walia" <fatpunj...@gmail.com>
Subject Re: Parameter Map is null after Ajax Request
Date Sat, 01 Dec 2007 22:25:32 GMT
Thanks for the reply, guys.

I am aware that the Servlet does not have the parameter map directly
and that they must be accessed through the request object. I don't
know if I said something to that effect to make you think otherwise,
but yes, my program accesses the HTML form data via
request.getParameter()

And I don't believe this problem has much to do with the way or order
in which things are being processed. To that end I think you were
looking to see if it was an error in JavaScript logic and I don't
think that is the case. One thing I forgot to mention is that I tested
the same web application on my local (Windows) machine and it works
there without problems using the exact same data input.

As I stated earlier, I was using Prototype 1.4 to submit my AJAX
request. I upgraded to 1.6, the current version, and found that this
fixed the problem. Why? I have no idea. I thought the culprit might be
the Form.serialize() method which I am using to pass the form data to
the input into servlet but they seem to match perfectly. I will keep
investigating and let you know if I find anything conclusive.

Randeep

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message