tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Sayre" <richardsa...@gmail.com>
Subject HTTP 1.1 Not Supported
Date Wed, 05 Dec 2007 17:32:56 GMT
I have a C Sharp Pocket PC application that is hitting a Tomcat web
server and getting some data from that server.  With Tomcat 4.1 this
application is working fine, but since I upgraded to Tomcat 6 it
stopped working.

Most of the application works with Tomcat 6.  When It does work here
is the scenario:


1. My C# app sends a request to /webapp/getCustomers.jsp?custId=1
through "POST"
2. The jsp servlet gets some XML from the model and puts it into a
String and prints it using the output stream
3. the C# App receives the data ok through a response object


When it doesn't work the following occurs:


1.       Pocket Pc requests a page through POST and opens a stream and
writes some data to the stream (Some xml data)
2.       The pocket pc app tries to obtain a Response object from the request
3.       On the line of code that tries to obtain a response I get a
server error



HTTP/1.1 505

HTTP Version Not Supported..Server: Apache-Coyote/1.1..Date: Tue, 04
Dec 200713:08:21 GMT..Connection: close

Which is weird since my connector is as follows:

<Connector URIEncoding="utf-8" connectionTimeout="20000" port="8084"
protocol="HTTP/1.1" redirectPort="8443"/>

I am using Tomcat 6.0.14 which came bundled with Netbeans 6.

Thank you,

Rich

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message