tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Ciarniello <dciarnie...@cityxpress.com>
Subject Re: apxs problem
Date Wed, 12 Dec 2007 18:11:38 GMT
Rainer Jung wrote:
> If you put the jk modules into your apache rpm, you couple the 
> lifecycle of those two together. So you need to build and deliver a 
> new rpm whenever at least one of apache httpd and of jk have a new 
> version, you want to deploy.
>
> The release cycles of httpd and jk are very different from each other, 
> so you might want to consider unbundling and maybe not even installing 
> jk into the httpd directory, but in a different tree. That will make 
> your updates and rollbacks easier.
>

This isn't really an issue since we are very conservative when it comes 
to deploying servers - we are, after all, still using Apache 2.0.55 and 
mod_jk 1.2.15.  Having said that, it doesn't look like I will be able to 
do what I was hoping to do so separate RPMs it is.

Thanks for the help,
Dan.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message