tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Ciarniello <dciarnie...@cityxpress.com>
Subject apxs problem
Date Tue, 11 Dec 2007 22:56:32 GMT
I am putting together RPMs for apache and tomcat and I want to include 
the mod_jk connector with the apache RPM but I get an error that apxs 
cannot be found even though I give the full path to apxs.

The commands that I do are

(in apache)
./configure  --enable-ssl=shared --enable-so --with-ldap --enable-ldap 
--enable-auth-ldap
make
make DESTDIR=/var/tmp/httpd-2.0.55-1-root install

(in jakarta-tomcat-connectors-1.2.15-src/jk/native)
./configure 
--with-apxs=/var/tmp/httpd-2.0.55-1-root/usr/local/apache2/bin/apxs

The configure fails with:
checking for perl... /usr/bin/perl
could not find /var/tmp/httpd-2.0.55-1-root/usr/local/apache2/bin/apxs
configure: error: You must specify a valid --with-apxs path

Note that since I'm building for purposes of packaging, I'm not 
installing apache in its intended location but in a temporary location.  
This is obviously the problem since if I do actually install apache, the 
connector configure script works fine.  Thing is, I don't want to have 
install apache just to build the connector.  Is there any way to do this?

Thanks,
Dan.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message