tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Delian Krustev <tom...@krustev.net>
Subject Re: AccessControlException in Coyote Http11Processor (Tomcat 6.0.14). Bug in Coyote ?
Date Thu, 06 Dec 2007 09:17:32 GMT
On Wed, 05 Dec 2007 22:13:00 +0000 Mark Thomas wrote:
> Did it happen straight away or did it work for a while and then fail?

Dec 3, 2007 10:14:24 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 152362 ms

.. 

Dec 3, 2007 10:17:22 PM org.apache.catalina.core.ApplicationDispatcher invoke
SEVERE: Servlet.service() for servlet jsp threw exception
java.security.AccessControlException: org/apache/coyote/Constants

I've tried it about 3 minutes after the restart.

>
> I am beginning to think that
> http://svn.apache.org/viewvc?view=rev&rev=505593 introduced a subtle timing
> issue. If Tomcat internal code causes Constants to be loaded, everything is
> fine. If the webapp code causes Constants to be loaded, it fails.

It goes live straight away, so I suppose some request from user web 
application might have already been served.

I've been observing this problem for quite a while, and it has been there all 
the time. 
The HTTP connector stays unused because of this problem.

You might be right -  may be the last time it did not appear because my test 
was done prior to a request to an application that triggers it.

>
> The fix would be to revert to the (System.getSecurityManager() != null)
> test.

I'd be glad to test the patch.


Cheers
--
Delian

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message